Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB headset disappearing devices


  • Please log in to reply
No replies to this topic

#1 MegiddoDoge

MegiddoDoge

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:34 PM

Posted 01 May 2017 - 08:43 PM

Hi, 

I'm not sure if this is the right topic to post this in, sorry if it isn't.

I have a Afterglow Prismatic wireless headset, and its been working fine for about 2 years now.  I use it for my PC, and for my Xbox One, and often swap it between the two.  However as of yesterday it no longer works properly on my PC.  When I plug it in, it'll appear on my playback devices list, however once I turn on my headset, the device disappears and I cannot get it to reappear without plugging the USB back in.  
I've tried every USB port on my PC and its always the same result.  I don't have another PC to test it on, however it does still work fine on my Xbox One and my TV.  

Currently on Windows 7.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users