Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Getting rid of Google Chrome Popup Blocker for good?

  • Please log in to reply
2 replies to this topic

#1 achzone


  • Members
  • 38 posts
  • Gender:Male
  • Location:Melbourne, Australia
  • Local time:08:49 AM

Posted 28 April 2017 - 04:39 PM

Hi Gang,
Have run into an annoying problem with the Google Chrome browser that I can't seem to defeat.
Google Chrome Version 58.0.3029.81 [Up to date at time of writing]
I use a third party Pop-Up blocker (Popup Blocker Pro) which is my preferred solution to blocking Pop Ups but no matter how often I've tried, I can't seem to get Chrome's built in Popup Blocker to stop loading.
I've gone into chrome://settings/content several times and set Pop-ups to 
"Allow all sites to show pop-ups" which results in the built in pop-up blocker to behave as I want, but that only seems to work for the current browsing session. 
If I close the Chrome Browser and re-open it, Chrome settings revert back to "Do not allow any site to show pop-ups (recommended)"
Can't seem to make it stick to "Allow all sites to show pop-ups" no matter what I try.
Steps tried to date:
  • Tried Resetting Chrome to defaults by going to Settings > Show advanced settings... > Reset Settings
  • Uninstalled Chrome, Rebooted, Reinstalled Chrome
Neither of the above attempts resolved the problem.
Anyone here come across this and have a solution to it?

BC AdBot (Login to Remove)


#2 achzone

  • Topic Starter

  • Members
  • 38 posts
  • Gender:Male
  • Location:Melbourne, Australia
  • Local time:08:49 AM

Posted 28 April 2017 - 06:16 PM

The problem was a corrupt Google Chrome Profile at C:\Users\{username}\AppData\Local\Google\Chrome\User Data
Renaming the Default folder and allowing Chrome to create a new profile fixed the problem and now the "Allow all sites to show pop-ups" setting sticks.
Answer found with the help of the folks at experts-exchange.com

#3 hamluis



  • Moderator
  • 56,435 posts
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:49 PM

Posted 29 April 2017 - 07:07 AM

Glad you resolved your issues...happy computing :).



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users