Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Change the default location/language of Google within Firefox


  • Please log in to reply
6 replies to this topic

#1 Mude

Mude

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 18 April 2017 - 10:40 AM

Hey everyone!

 

This is my situation: I live in Germany. I use Firefox as my web browser, and Google as my search engine. So if for example I was to type "Test search blabla" into the URL bar of Firefox and hit enter, it would go to www.Google.com which will redirect me to www.Google.de...

 

Surely there must be a way of changing it, so that when I type something into the URL bar and hit enter, it automatically uses www.Google.co.uk.

 

I've tried to use this search, as well as the Google search, but I came up with nothing useful to be honest. Somewhere in some different Forum, someone suggested messing around with Firefox by typing "about:config" into the URL bar, and deleting/changing certain parameters.

Since I'm rather a noob, I don't want to mess around with that, without having someone I can ask for help in case I mess things up. :smash:

 

Am I allowed to post the links to the websites with the suggested potential solutions?

This is my first post here. Please be kind. And if I've done anything wrong, please let me know. :)

 

Kind regards,

Mude



BC AdBot (Login to Remove)

 


#2 Just_One_Question

Just_One_Question

  • Members
  • 1,400 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:12:16 AM

Posted 18 April 2017 - 10:47 AM

Open 'Firefox'. Go to 'Option/Settings'. Find 'default search engines' or something like that. Uncheck them all. Type in on the free space for a default search engine 'www.google.co.uk . Click on 'add' or something similar. Close 'Option/Settings'. Close Firefox. Restart your computer. That's it.

#3 Mude

Mude
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 18 April 2017 - 10:57 AM

Thanks for the quick reply!

 

Unfortunately, there is no free space where I can add my own search engine. I can click "add more search engines...". But that just brings me to the Firefox-Add-Ons section.

 

 

Edited:

Hold on! Thanks. I managed to get it to work. I just searched for "Google UK" within the Add-Ons. There are several. So I think it's important to choose the correct one.

I'll post a screenshot of the one that worked for me, just in case someone will find this thread one day. Maybe it'll help :)

 

Thanks again for the fast help, mate!

QH4yVo8.png


Edited by Mude, 18 April 2017 - 11:04 AM.


#4 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:16 AM

Posted 18 April 2017 - 11:28 AM

Open 'Firefox'. Go to 'Option/Settings'. Find 'default search engines' or something like that. Uncheck them all. Type in on the free space for a default search engine 'www.google.co.uk . Click on 'add' or something similar. Close 'Option/Settings'. Close Firefox. Restart your computer. That's it.

Is it black humor or something else?



#5 JohnC_21

JohnC_21

  • Members
  • 24,452 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:16 PM

Posted 18 April 2017 - 11:49 AM

Possibly this add-on

 

https://addons.mozilla.org/en-US/firefox/addon/googleuk/

 

Edit: Missed the edited post. :blush:


Edited by JohnC_21, 18 April 2017 - 11:57 AM.


#6 Just_One_Question

Just_One_Question

  • Members
  • 1,400 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:12:16 AM

Posted 18 April 2017 - 11:51 AM


Open 'Firefox'. Go to 'Option/Settings'. Find 'default search engines' or something like that. Uncheck them all. Type in on the free space for a default search engine 'www.google.co.uk . Click on 'add' or something similar. Close 'Option/Settings'. Close Firefox. Restart your computer. That's it.

Is it black humor or something else?
:lmao: I was in a hurry, so I provided the 'leanest' version of the explanation possible, lol. But hey... it worked!:lmao:

Edited by Just_One_Question, 18 April 2017 - 11:52 AM.


#7 JohnSovereign

JohnSovereign

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:16 AM

Posted 21 September 2018 - 09:23 PM

Well... it's September of 2018 and it finally rose to my conscious level that I was getting fed up with Google redirecting me to the current region where I am at (Thailand).

 

I open Google from my bookmarks and it is either in English or sometimes it is in Thai, and I have to click the option below the 'search' field to redirect back to English.

 

Or... Google opens in English and that is good, but when I click on 'Gmail' up top right, I get to my sign in page and it is always in Thai. So I have to scroll down and select 'English' in the drop down and I get redirected back to the Google search page, click on Gmail and get redirected back to the Thai language sign in page (as if my measures did not sink in) :crazy: .

 

So... after an hour or two of studying this subject, I got answers such as...

 

----------------------------------------------------

"To turn off the feature, reveal the hidden preference "geo" (set to 'True') in about:config, and set to false."

-----------------------------------------------------

 

...and this...

 

------------------------------------------------------------

"Google.com will redirect to a local site when you're traveling, based on geolocation using data about your current ISP connection. To bypass that, you can use "https://www.google.com/ncr" (NCR = no country redirect)

This sets a cookie that Firefox sends to Google.com with every request so Google remembers that you don't want to be redirected. If you clear Google cookies, either manually or at shutdown or using an add-on, then you have to set the ncr cookie again the next time it happens.

------------------------------------------------------------------

 

RESULTS? No changes. Same problem. Moreover, I now have to remember to disable my cookies being deleted and Google defaulting back to the current region language and yada yada yada. You get the point.

 

I finally stumbled upon a solution which (THUS FAR) works well and after setting it I can forget everything and my Google Search is always in English, and when I click 'Gmail' the sign in page is in English and all the Thai options are gone gone gone!

 

Here is the post (credit to Šime Vidas) at this thread:

 

------------------------------------------------------------------------------------------------

I've found it! The "Search Settings" page is available at this URL:

https://www.google.com/preferences#languages (set to "English")

Google does not link to this page from its search start page.

-------------------------------------------------------------------------------------------------

 

Yes, you read that correctly... "Google does not link to this page from its search start page."!!!  I deduce that the language problem has nothing to do with the browser you are using and see it as Google being used by the browser. What this means is that I need to look for changes in Google and forget about dealing with configuring Firefox, Safari, Opera, Chrome, etc.

 

"Google does not link to this page from its search start page." really got me mad because those cusses don't tell you this anywhere in their search page.

 

So, go to that link and you will see that the default setting is set to "current region" (or something to that effect), and select the "show more" drop-down (if your language region is not showing) and select your language and click "save" at the bottom of the page.

 

Google should now show your language and Gmail sign in and everything else in your language and not redirect to the local region.

 

I may be wrong, but so far this is the case, so I hope it works for you. I have not seen this particular solution in over 40 or so websites that give user or techie solutions. They all go with the same script about changing option settings and about:config settings and getting addons and entering special URLS in the browser, but it is not the browser's problem... it is Google's prpblem. This solution is the only one I know of that address Google from within Google.

 

Let me know if this helps, and I hope it does. This works in Firefox 56.02. I am certain it should work in ALL browsers who "tap" into Google, since Google is letting these browsers use their (Google's) services and Google's own default settings, which are apart from the browsers themselves and their respective settings.

 

Note: as an added precaution, after saving and closing that page, I closed my Firefox browser and reopened in case this measure is needed to activate the changes.

 

Ya Bless


Edited by JohnSovereign, 21 September 2018 - 09:30 PM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users