Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port forwarding not working


  • Please log in to reply
7 replies to this topic

#1 Princerr5

Princerr5

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:41 PM

Posted 16 April 2017 - 02:15 PM

Hey, I've been trying to open port 25565 for 3 days. I've been looking through every result on google, and nothing worked for me. I can run my server and then log on with either 'localhost' or '192.168.1.100'. I've added a static ip, and attached are my router port forwarding page. I even tried auto-port forwarders like "simple port forwarding" and "portforward network utilities". This is really frustrating and any help would be greatly appreciated. I've completely disabled windows firewall and have disabled SPI on my router. I've even tried DMZ. I use DD-WRT if that helps. Attached are router settings page, ipconfig, and canyouseeme test.

 

Make and model of computer - Custom built

How the computer is connected (wireless or wired) - Wireless but also tried wired

Make and model of Router - DIR 810L with flashed DD-WRT

Approximate Distance From the router the PC is if its a wireless connection - 15 ft

What type of internet you have (Dsl, Cable, T-1,etc..) Sorry I'm a noob and don't know what this means. I'm guessing it's DSL.
 

EDIT: Solved - Have carrier-grade NAT. Impossible to port forward.

Windows IP Configuration
Wireless LAN adapter Local Area Connection* 2:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Ethernet adapter Ethernet:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::e120:e58a:3ec5:1d6f%7
IPv4 Address. . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
Ethernet adapter Bluetooth Network Connection:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Wireless LAN adapter Wi-Fi:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Tunnel adapter isatap.{5A4D4FC0-0A7A-4C4F-942D-F3F87AD81AB4}:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:8ab:fbff:c014:714b
Link-local IPv6 Address . . . . . : fe80::8ab:fbff:c014:714b%11
Default Gateway . . . . . . . . . : ::

Attached Files


Edited by Princerr5, 17 April 2017 - 10:43 AM.


BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:05:41 PM

Posted 16 April 2017 - 03:51 PM

The problem has to do with your WAN IP address.  Since it starts with 10.x.x.x that means that it is a private address.  Port forward will fail unless you have a public IP address, with the exception of other devices on the same network.



#3 Princerr5

Princerr5
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:41 PM

Posted 16 April 2017 - 04:55 PM

The problem has to do with your WAN IP address.  Since it starts with 10.x.x.x that means that it is a private address.  Port forward will fail unless you have a public IP address, with the exception of other devices on the same network.

How exactly can I fix this? I tried to go 10.21.104.1 for the default gateway, but it didn't work. I do not have 2 routers, only a modem and a router. How do I get a public address? Don't hesitate to ask me for any information.


Edited by Princerr5, 16 April 2017 - 07:30 PM.


#4 toofarnorth

toofarnorth

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:41 AM

Posted 17 April 2017 - 08:19 AM

I agree with Kilroy. The 10.x.x.x address is not reachable through the internet and any port forwarding you are doing is not working

This is probably due to the lack of IPV4 addresses meaning that your ISP does something called Carrier Grade NAT.
https://en.wikipedia.org/wiki/Carrier-grade_NAT

To resolve this you need to check with your ISP if they provide a subscription for a permanent IP address.
If not your option is to switch to a provider that can supply you with one

HTH!

 

tfn



#5 Princerr5

Princerr5
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:41 PM

Posted 17 April 2017 - 10:36 AM

I agree with Kilroy. The 10.x.x.x address is not reachable through the internet and any port forwarding you are doing is not working
This is probably due to the lack of IPV4 addresses meaning that your ISP does something called Carrier Grade NAT.
https://en.wikipedia.org/wiki/Carrier-grade_NAT
To resolve this you need to check with your ISP if they provide a subscription for a permanent IP address.
If not your option is to switch to a provider that can supply you with one
HTH!
 
tfn


If there is nothing I personally can do, then I'm screwed because the apartment I live in is locked to only CenturyLink ISP. Thanks anyway though. 


Edited by Princerr5, 17 April 2017 - 10:39 AM.


#6 toofarnorth

toofarnorth

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:41 AM

Posted 17 April 2017 - 11:28 AM

Hello again

 

It seems CenturyLink does provide static IP addresses. Read more here:
http://internethelp.centurylink.com/internethelp/static-setup-res.html

Hth!

 

tfn



#7 Princerr5

Princerr5
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:41 PM

Posted 17 April 2017 - 03:20 PM

Hello again

 

It seems CenturyLink does provide static IP addresses. Read more here:
http://internethelp.centurylink.com/internethelp/static-setup-res.html

Hth!

 

tfn

There's a problem with that, I'm not the account holder, my apartment is. (I know, it's wierd) Regardless, thank you for expanding my knowledge. Is there an alternative to port forwarding? Maybe with VPN's or something?


Edited by Princerr5, 17 April 2017 - 03:50 PM.


#8 toofarnorth

toofarnorth

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:41 AM

Posted 18 April 2017 - 12:22 PM

Hi again.

A VPN might work. Since you have DD-WRT it should have an OpenVPN client built in

If you dont plan on using more than 15GB of traffic pr month Amazon gives you 12 months free before you have to start paying.
https://aws.amazon.com/marketplace/pp/B00MI40CAE?qid=1492535902996&sr=0-1&ref_=srh_res_product_title

Look for the Free Tier on the right hand side of the screen

This should be plenty to host your own minecraft server :)

Here is some info on how to set up DD-WRT:
https://docs.openvpn.net/frequently-asked-questions/using-dd-wrt-with-openvpn-access-server/

Hth!

tfn

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users