Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mouse won't work in Microsoft Edge after Creators update


  • Please log in to reply
4 replies to this topic

#1 TrueSkyDemon

TrueSkyDemon

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:24 PM

Posted 12 April 2017 - 05:45 PM

Hi, I just updated my Windows with Creators update, and everything seems fine, but there is a problem with Microsoft Edge, my mouse will not able to click or scroll any of the web contents, but I can click on all the tools on top of the browser (address bar, tool bar, settings.. etc) or I can even use keyboard to scroll up and down, use "Tab" key to jump into the web contents, but just mouse is unable to click anything, does anyone has the same problem? or know a way to fix this issue?

 

Thanks.



BC AdBot (Login to Remove)

 


#2 TrueSkyDemon

TrueSkyDemon
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:24 PM

Posted 13 April 2017 - 09:26 AM

Nevermind, after a long troubleshooting, I finally find out that the program "DimScreen" causing it, I use this program to dim my screen to prevent flickers on my laptop, but it seems the Creator update made changes to Microsoft Edge and now it will not allow me to click anything with mouse when DimScreen is running, once I close the program I'm able to use mouse with Microsoft Edge again. 


Edited by TrueSkyDemon, 13 April 2017 - 09:25 PM.


#3 Jasmintai

Jasmintai

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:24 PM

Posted 15 April 2017 - 02:47 PM

Glad I ran across this.  It gave me a hint.  I use Cursor FX for my mouse cursor.  When I changed the cursor back to the Windows default mouse, then Edge worked properly.



#4 medab1

medab1

  • Members
  • 698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:earth
  • Local time:10:24 PM

Posted 15 April 2017 - 09:43 PM

You can always check here---

 

screenshot_395.jpg



#5 Bettini

Bettini

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:24 AM

Posted 30 June 2017 - 07:10 AM

Hey there! Thank you for this post! This also gave me a hint! In my case it was the Nvidea GeForce Experience that was causing a bug on Edge! Thank you again for this post.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users