Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows cannot open this file: PIF


  • Please log in to reply
7 replies to this topic

#1 Walking Through

Walking Through

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Boston
  • Local time:02:08 PM

Posted 08 April 2017 - 06:14 PM

Hello -

 

Platform: Windows XP SP3 on an HP Pavilion a1240n plus all patches since then.. and including the one right after XP support was dropped.  The system boots up nicely, no problems, everything seem to work.  Once a week scans with Malwarebytes Anti-Malware and SuperAntiSpyware.

 

I still use XP... there's a number of peripherals I use for which 64-bit drivers aren't available.

 

I have a copy of Microsoft QuickBASIC 1.1 migrated from an old computer (it still runs nicely in a CMD window).  I can start QB from a CMD prompt.  I tried creating a short-cut to it on the desktop.  Windows XP creates the shortcut, names it "Microsoft QuickBASIC.pif".

 

The icon is the one XP puts up when it doesn't know what to put up.

 

Double-left clicking pops up the attached image.

 

Attached File  NOPIF.PNG   17.82KB   0 downloads

 

(it's a pane saying "Windows cannot open this file:  File:  Microsoft QuickBASIC.pif).

 

This used to work.  I look for the PIF association in the registry and don't see it.

 

  1. A search though the net produces a reference to Microsoft's KB92077 ... and going for that produces a message that the page doesn't exist.  Does anyone have a copy or can point me to where one exists?
  2. What are the steps to restore the PIF association in Windows XP ?

 

Thank you.


Edited by Walking Through, 08 April 2017 - 06:17 PM.


BC AdBot (Login to Remove)

 


#2 hdriscoll

hdriscoll

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:08 PM

Posted 08 April 2017 - 06:19 PM

Is this of any help?

https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/windows_pif_create.mspx?mfr=true



#3 Walking Through

Walking Through
  • Topic Starter

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Boston
  • Local time:02:08 PM

Posted 08 April 2017 - 07:31 PM

Not really. No problems creating the PIF. But double-left clicking on the icon pops up that error pane. In RegEdit... HKEY_CLASSES_ROOT does not have .pif anywhere. It goes .pic, .pict, then .pip . No .pif.

#4 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:02:08 PM

Posted 08 April 2017 - 07:50 PM

If you are trying to create a shortcut on the desktop to run QB browse to the QB.exe file. Right click and select Create Shortcut. Copy the Shortcut to the desktop.

 

https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/windows_fcab_link.mspx?mfr=true



#5 Walking Through

Walking Through
  • Topic Starter

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Boston
  • Local time:02:08 PM

Posted 08 April 2017 - 09:33 PM

Just tried that.

 

Windows Explorer creates the "Shortcut to Microsoft QuickBASIC.pif" icon in the directory containing the executable.  Then I dragged the shortcut to the desktop.  It appears where dropped.

 

And that error pane still appears when trying to start it.

 

Here is the desktop icon:

 

Attached File  NOPIF2.PNG   4.32KB   1 downloads

 

 



#6 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:02:08 PM

Posted 09 April 2017 - 07:04 AM

A shortcut should not have any extension. If you right click and select properties you should get a dialog box with a number of tabs.

 

I believe QB is an old DOS program and this is the problem. From this page the only way to start it ion XP s by doing your method. The shortcut should look like the one on the page.

 

https://chortle.ccsu.edu/QBasic/chapter00/bc00_6.html



#7 Walking Through

Walking Through
  • Topic Starter

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Boston
  • Local time:02:08 PM

Posted 09 April 2017 - 09:26 AM

I agree... the link shouldn't be named that.  Just for grins, tried renaming the link file to QuickBASIC.pif.  Didn't help.  Then tried QuickBASIC.lnk.  That didn't work, either.

 

Right-clicking on the QuickBASIC icon and selecting Properties... here are three screenshots:

 

Attached File  NOPIF3A.PNG   34.52KB   0 downloads

 

Attached File  NOPIF3B.PNG   19.24KB   0 downloads

 

Attached File  NOPIF3C.PNG   16.57KB   0 downloads

 

==========

 

Just for casual curiosity, the "standard" "hello.c" program was compiled and turned into a .COM program using EXE2COM.  Running it from a CMD prompt produces the familiar "hello world".  Creating a desktop shortcut produced this icon:

 

Attached File  NOPIF3D.PNG   2.1KB   0 downloads

 

Double-left clicking on that icon produces the same fail: Windows doesn't know how to open the file.

 

The created shortcut in the Desktop directory is named "TEST.COM.pif" .

==========

 

Granted, QuickBASIC is a 192K EXE file.

 

I just tried creating a shortcut to Notepad.  The correct icon appears and the Desktop directory contains Notepad.lnk .

 

The created shortcut to QuickBASIC is named "Shortcut to Microsoft QuickBASIC.pif"

 

Just to muddle the waters a little more.. just tried creating a desktop shortcut to C:\Windows\System32\tree.com .  Tree.com came with Windows XP.

 

Right-click on desktop, navigate New --> Shortcut, select program, accept default name, and up pops an icon selector.  I select "MS-DOS" for the icon.

 

And up pops the same icon as for Shortcut to QuickBASIC with the name "tree.com.pif" .

 

1. Wrong icon.

2. Double-left click on that wrong icon pops up the "Windows can't open this file" pane.

 

Observation:

A. Windows (Explorer) isn't creating the shortcut properly.

B. Maybe it is creating the shortcut properly but it's not handling it properly afterwards.

 

Those PIF files are 2855 bytes long.

 

Found this while searching for a solution:

 

http://www.drdobbs.com/architecture-and-design/undocumented-corner/184409042

 

There is a _default.pif file in C:\Windows.

 

According to that article, there should be a file named "winoa386.mod" somewhere in C:\Windows.

 

Hm.  My computer doesn't have that file.  Rather, it's not in either C:\Windows or in C:\Program Files trees.  And there is no mention of "winoa" in the registry, either.

 

Hm.  Maybe, back in the days of support, Microsoft pushed out a patch that removed the feature due to security concerns?


Edited by Walking Through, 09 April 2017 - 09:31 AM.


#8 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:02:08 PM

Posted 09 April 2017 - 09:56 AM

For some reason the PIF extension, program information file, is not properly associated on your computer. I am not sure on how to fix this association. 

 

Note: It looks like a security patch disabled .PIF files  because of a vulnerability. This could have been provided on a Windows Update.

 

http://www.thewindowsclub.com/fix-it-lnk-and-pif-file-shortcuts-vulnerability-in-windows-shell


Edited by JohnC_21, 09 April 2017 - 10:06 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users