Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System Restore failing (0x80070091)


  • Please log in to reply
2 replies to this topic

#1 Sundial

Sundial

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:43 PM

Posted 05 April 2017 - 09:12 PM

I've been trying to use Windows 10's System Restore to revert my computer to a restore point I made 4 days ago, but it's been giving me the following error:

System Restore failed while restoring the directory from the restore point.
Source: AppxStaging
Destination: %ProgramFiles%\WindowsApps
An unspecified error occurred during System Restore. (0x80070091)

After looking it up online, it seems like this isn't unheard of, and is a problem related to the hidden WindowsApps folder that could be caused by, among other things, antivirus programs. Yesterday, I reinstalled Malwarebytes 3.0 to fix a bug and as a result got a new trial for Malwarebytes Premium, which includes a self protection module. I uninstalled MBAM, ran the MBAM-clean tool to remove the remnants, and tried to use System Restore again, but no luck.

 

In the past few days prior to my restore point, I also had installed VideoPad and Windows Live Essentials 2012. I've removed them too just in case they were messing things up, but System Restore still doesn't seem to work. I tried using System Restore in the recovery environment, and nope, still getting the same error.

 

The disk and system files are in good shape, so I'm not exactly sure of what's going on here. Maybe Malwarebytes left something behind? In any case, I think I've exhausted all the approachable solutions that I could find, so I'd appreciate any guidance or advice that you guys might have for how I should proceed. Thanks!



BC AdBot (Login to Remove)

 


#2 medab1

medab1

  • Members
  • 698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:earth
  • Local time:02:43 PM

Posted 05 April 2017 - 11:29 PM

Try ---

 

https://www.macrium.com/reflectfree

 

After Windows restore points failed me many times I quit using them.



#3 tony007

tony007

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Local time:07:43 PM

Posted 06 April 2017 - 02:34 AM

I have the same problem see my post '

can someone tell me a way to get system restore to work ' the only other app I know of that works in the same way as system restore is erunt, but I have been told on another forum that this is not suitable for windows10 but when I run it as administrator it seems to work. I am looking for something else macrium reflect might do when I can download it. I have tried regedit and saved my registry so that might do if I ever need it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users