Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

can't delete folder


  • Please log in to reply
4 replies to this topic

#1 markab

markab

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:43 PM

Posted 30 March 2017 - 06:23 PM

Hi,

 

I'm trying to delete a folder on my D: drive. No matter what I do, the computer refuses to let me. When I try, it gives me a "You'll need to provide administrator permission to delete this folder". I continue, it gets to the end of the deletion, stops, and tells me that "You need permission to perform this action" and says that I require permission from my own user account to delete the folder. I just have to stop the deletion. I tried deleting all the files in the folder instead and there are two folders in there it wouldn't let me delete either. 

 

I've tried using IOUnlocker and I've tried editing under the properties/security tab. It shows that my account has delete permissions but I still can't delete anything. I made sure I show as the file's owner and nothing. I tried to give users full permission by going to my D drive's properties since they didn't have full control, but it threw up an error as soon as it got to the folder I can't delete. It then threw several identical ones as it went through all the different folders and files that comprise my Skyrim installation, which is where the problem folder in question exists. 

 

If anyone knows how to fix this I would appreciate the help. I've been struggling with it for the past hour and have made no headway.

Thanks!

 

EDIT: I got rid of the folder by going back through it and deleting each subfolder from the bottom up. This shouldn't be the intended behavior though? I now have a bunch of folders that read as 0kb empty when I hover over them but trying to delete them gives me an 'access is denied' error. In properties it tells me I must have read permissions to see properties of the object, and going advanced reads as 'unable to display current owner' & attempting administrator permission to view properties does not work.


Edited by markab, 30 March 2017 - 07:14 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:43 PM

Posted 30 March 2017 - 07:45 PM

When I have issues with zero byte files or folders that do not delete I boot a live linux disk. For this I would recommend fatdog64. But first it is necessary to disable the fast startup feature of Windows 10 and then use the following command in a command prompt to do a complete shutdown before booting fatdog.

 

shutdown -s

 

This is because of Windows 10 hybrid shutdown uses a hibernation file that does not permit write access to the drive.

 

You can burn a CD of fatdog by right clicking the iso file and selecting Burn Disk Image. You can also use Rufus to create a bootable USB flash drive.

 

Rufus Instructions:

Run Rufus with the USB flash drive attached. Select MBR partition scheme for BIOS and UEFI. Leave all boxes as checked. Where FreeDos is shown in the dropdown box select iso image, click the icon, and browse to the Fatdog iso file. Press Start. Any data on the flash drive will need to be backed up as the drive will be formatted.

 

Fatdog delete instructions;

Boot Fatdog to the desktop. In the lower left of the desktop you will see your partitions listed as sda1...sda2...sda3...etc. On an upgraded computer from 7 or 8 you will see quite a few. Normally your Windows partition will be on sda3 but it may be different in your case. Click once on the partition icon. The partition should mount and a File Manager Window will open. If you do not see your files/folders then close the Window and click on another sdaX icon. Once you have found your Windows partition you only need to click once on a folder to open it. Right click the folder you wish to delete and select delete. Make sure you are deleting the correct folder. There is no recovery if the wrong folder is deleted.

 

Fatdog64   Fatdog64-710.iso

 

I don't know your computer model but most will give you a boot menu when tapping a key at boot. Select your boot device. Because you are doing this with a linux outside of Windows permissions will not be a problem. 

 



#3 markab

markab
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:43 PM

Posted 30 March 2017 - 09:45 PM

Thank you! However a reboot did seem to fix the issue -- not nearly completely, or for long, but enough for me to delete the empty folders and get everything working.

However, I then attempted to run both sfc /scannow and DISM and they both closed with errors before even starting to run. Sfc told me it couldn't initialize the repair service; DISM told me 'the object exporter specified could not be found'.

This computer and its copy of Win 10 are both barely two weeks old. I honestly have no clue how to proceed. Should I reinstall Windows or is there some other way to solve this?

#4 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:43 PM

Posted 30 March 2017 - 09:52 PM

I would start another thread explaining the sfc /scannow and DISM errors even though the ability to not delete the folder may be related. 



#5 markab

markab
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:43 PM

Posted 30 March 2017 - 09:55 PM

Alright, I will do that now. Thanks for your help:)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users