Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Ethernet" doesn't have a valid IP configuration (please help)


  • Please log in to reply
13 replies to this topic

#1 Nicholas_91

Nicholas_91

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 26 March 2017 - 09:28 PM

Hi all,

I'm using a power socket adapter to run ethernet from the router upstairs to my downstairs pc. Everything was working fine until one day it says the ethernet connection is "Unidentified" and after trouble shooting, it says ""Ethernet" doesn't have a valid IP configuration".

I've tried many things and have spent hours configuring ipv4, getting the latest drivers, and trying to configure other things based on the other cases of this. I'm really at a loss a this point.

I've posted my ipconfig /all below. Please let me know if there are any ideas for a fix. 
Thank you - Nick
-----


Windows IP Configuration

Host Name . . . . . . . . . . . . : NSH
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 12-34-56-78-90-AB
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::3571:f86f:5704:a757%15(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.167.87(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 192.168.100.1
DHCPv6 IAID . . . . . . . . . . . : 264040059
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-69-D7-81-12-34-56-78-90-AB
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 3:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : FC-F8-AE-7C-1C-C2
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Dual Band Wireless-AC 7260
Physical Address. . . . . . . . . : FC-F8-AE-7C-1C-C1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2600:8806:100:1b10:944d:7217:8a9c:caab(Preferred)
Temporary IPv6 Address. . . . . . : 2600:8806:100:1b10:48a4:7529:1b63:2a91(Preferred)
Link-local IPv6 Address . . . . . : fe80::944d:7217:8a9c:caab%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.8(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Sunday, March 26, 2017 4:06:18 PM
Lease Expires . . . . . . . . . . : Sunday, March 26, 2017 10:51:48 PM
Default Gateway . . . . . . . . . : fe80::3a70:cff:fe12:176%7
192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 66910382
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-69-D7-81-12-34-56-78-90-AB
DNS Servers . . . . . . . . . . . : 2001:578:3f::30
2001:578:3f:1::30
2001:578:3f::30
68.105.28.11
68.105.29.11
68.105.28.12
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : FC-F8-AE-7C-1C-C5
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 4:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{B2964998-8E97-490D-8BC6-558674D0B9F8}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{B7D6BCBA-3AF7-4494-93C6-75DC5612F0B9}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes



BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:11:28 PM

Posted 26 March 2017 - 11:49 PM

You are being given a ipipa address, rather that a dhcp assigned one.

Autoconfiguration IPv4 Address. . : 169.254.167.87(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 192.168.100.1

Open a cmd prompt and right click and choose run as administrator and type:

netsh interface reset press enter
netsh winsock reset press enter
nbtstat -R press enter
ipconfig /flushdns press enter and restart pc

 

Works now?


Edited by TsVk!, 26 March 2017 - 11:53 PM.


#3 Nicholas_91

Nicholas_91
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 27 March 2017 - 09:13 AM

No, that didn't work. Thanks though.



#4 Nicholas_91

Nicholas_91
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 27 March 2017 - 09:34 AM

It still had this under ipconfig /all after I entered the commands and restarted.

 

Ethernet adapter Ethernet:
 
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 12-34-56-78-90-AB
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3571:f86f:5704:a757%15(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.167.87(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 264040059
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-69-D7-81-12-34-56-78-90-AB
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled


#5 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:08:28 AM

Posted 27 March 2017 - 10:49 AM

Is your network cable connected?  It looks like the wireless card has a valid IP address, 192.168.0.8, but the gateway is on a different network 192.168.100.1.

 

Has this ever worked?

 

What did you change before it stopped working?

 

Have you checked the router settings?



#6 Nicholas_91

Nicholas_91
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 27 March 2017 - 10:52 AM

This wireless works fine, and the Ethernet was working all of last week until yesterday.  I changed nothing and it just stopped working, it seems like it randomly stopped working.  I'm not sure what router settings I should change.



#7 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:08:28 AM

Posted 27 March 2017 - 11:01 AM

The wireless is using an IPv6 gateway and the gateway for the NIC (Network Interface Card) is IPv4, but on the different network.

 

I would check to see what the IPv4 address of the router is, guessing 192.168.0.1.

 

Check your network card settings for the LAN (Local Area Network) NIC and see if you have something set and it is not using DHCP (Dynamic Host Configuration Protocol).

 

The real question is where did the gateway of 192.168.100.1 come from?  As that is the main part of your issue.

 

Have you restarted the PC and the router?



#8 Nicholas_91

Nicholas_91
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 27 March 2017 - 11:08 AM

I've restarted PC and router multiple times.

 

I'm not sure about 192.168.0.1 vs. 192.168.100.1; If I type either in to my browser, it takes me to log in to the router settings.  

 

You'd have to be a little more specific on the LAN NIC settings and where I should look; I believe DHCP is checked in the settings for my Ethernet adapter.



#9 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:08:28 AM

Posted 27 March 2017 - 11:19 AM

Control Panel \ Network and Sharing Center \ Change adapter settings.

 

Select the LAN adapter and right click to select Properties (Administrative Rights will be required)

 

Go to the Internet Protocol Version 4 (TCP/IPv4) and press the Properties button.

 

Obtain an IP address automatically and Obtain DNS server address automatically should be selected.

 

Check the Alternate Configuration tab and make sure Automatic private IP address is selected.


Edited by Kilroy, 27 March 2017 - 11:20 AM.


#10 Nicholas_91

Nicholas_91
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 27 March 2017 - 11:21 AM

Yes, those settings have been in place the whole time.

 

Control Panel \ Network and Sharing Center \ Change adapter settings.

 

Select the LAN adapter and right click to select Properties (Administrative Rights will be required)

 

Go to the Internet Protocol Version 4 (TCP/IPv4) and press the Properties button.

 

Obtain an IP address automatically and Obtain DNS server address automatically should be selected.

 

Check the Alternate Configuration tab and make sure Automatic private IP address is selected.



#11 Kilroy

Kilroy

  • BC Advisor
  • 3,335 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:08:28 AM

Posted 27 March 2017 - 11:24 AM

You can try deleting the network card in Device Manager and then restarting the computer.  It should reinstall on the reboot.  That may fix the issue.

 

Otherwise you're looking at something on the router.



#12 Medicw

Medicw

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 08 August 2017 - 08:42 PM

I'm having the same issue, I've tried everything from New drivers to command prompt with no luck. Could this be a hardware issue?

#13 toofarnorth

toofarnorth

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:28 PM

Posted 09 August 2017 - 08:43 AM

Hello

 

This blog has helped me before when solving the 169.254.x.x issues.
Maybe it is useful for you too?

http://lyngtinh.blogspot.no/2011/12/how-to-disable-autoconfiguration-ipv4.html

 

Hth!

 

tfn



#14 Medicw

Medicw

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:28 AM

Posted 09 August 2017 - 11:37 AM

Ran it and sadly nothing still.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users