Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My wireless keyboard stopped working


  • Please log in to reply
1 reply to this topic

#1 skan

skan

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:58 PM

Posted 25 March 2017 - 06:27 AM

Hello.

 

I have a PC with Windows 10 Pro X64 1607 14393.969

 

Yesterday the Logitech MX wireless mouse and the Microsoft Ergonomic wireless keyboard stopped working suddenly.

 

After being more than two hours trying different things the mouse works but I'm not able to get the keyboard working yet.  So, we will focus only in the keyboard problem.

 

I would like to be able to use my keyboard.

 

I don't know if it's a Windows problem or a virus.

I'm sure it's  not a hardware problem because the same keyboard works during the boot process and in other computers too.

 

 

Steps I've already tried:

 

Uninstall and reinstall the drivers, from the device manager (I get an 1603 error in the Microsoft 2.4GHz Transceiver) or from the Microsoft software tool, it says it's not able because it's already installed, though I have reinstalled it.

 

Do the same from Windows Safe mode. Error 1601.

 

I've tried moving the keyboard receiver to a different prot.  Then Windows pops a small window showing it's installing drivers, the window closes but the problem persists.

 

I have run   sfc /scannow 

I have checked System components and Componenents Store Corruption   with a trial of  Windows 10 manager.

 

Restore older points:  Not available. I don't remember I had disabled them.

 

Boot from a Windows 10 DVD to repair my installation. 

If I had to reinstall Windows I need to keep all my old settings and programs.

When I ask it to resinstall it says I can't keep my files because it can't find a proper installation.

 

Windows update history says "Microsoft HIDClass error 0x800705b3"

 

I've used Ccleaner, adwcleaner, malwarebytes, and eset online to clean some minor problems.  

No dangerous malware has been detected.

 

Rkill gives this strange message:

 

Checking Windows Service Integrity:
 
 * gagp30kx [Missing Service]
 * IEEtwCollectorService [Missing Service]
 * IoQos [Missing Service]
 * nv_agp [Missing Service]
 * TimeBroker [Missing Service]
 * uagp35 [Missing Service]
 * uliagpkx [Missing Service]
 * WcsPlugInService [Missing Service]
 * wpcfltr [Missing Service]
 * WSService [Missing Service]
 
 * agp440 [Missing ImagePath]
 
 * AJRouter => %SystemRoot%\system32\svchost.exe -k LocalServiceNetworkRestricted [Incorrect ImagePath]
 * WpnService => %systemroot%\system32\svchost.exe -k netsvcs [Incorrect ImagePath]
 
 * vmicrdv => %SystemRoot%\System32\icsvcext.dll [Incorrect ServiceDLL]
 * vmicvss => %SystemRoot%\System32\icsvcext.dll [Incorrect ServiceDLL]
 
None of this solutions worked.
Other things in my Windows seem to work proprly.
NOw I'm writing from a different computer.
 
Regards

Edited by skan, 25 March 2017 - 07:06 AM.


BC AdBot (Login to Remove)

 


#2 skan

skan
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:58 PM

Posted 25 March 2017 - 10:58 AM

OK, after trying hundrends of things I found the solution.

I post it here just in case anybody needs it.

After pressing "upgrade driver" you don't have to point to the Internet nor the MS tool for that keyboard but you need to point to c:\Windows\winsxs instead.

 

It's strange because I hadn't change it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users