Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Switched off Microsoft services in msconfig, can't log in


  • Please log in to reply
14 replies to this topic

#1 Suzze

Suzze

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 04:03 AM

I, very cleverly, when doing a clean boot to remove some very annoying update messages, managed to deactivate Microsoft services in msconfig. Now I can’t login – no login screen – what a muppet.

 

I downloaded the Windows 10 media creation tool with my laptop onto a USB stick and tried to repair my PC but to no avail. I am a bit reluctant to install windows 10 again as I guess I will lose everything on the PC (althought it was interesting on upgrading from 8.1 to 10, all files were intact).

 

Anyway, if anyone has any ideas how I can fix this I would be most grateful! Thank you.

 



BC AdBot (Login to Remove)

 


#2 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,940 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 PM

Posted 23 March 2017 - 04:26 AM

Boot into safe mode ?

 

either use system restore there....or get into msconfig from there..?

 

http://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy


#3 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 04:54 AM

Thank you very much Outback Aussie. Unfortuntely I cannot boot into safe mode. I have to be logged in to use option 1. option 2 says you can do it from the login screen. When I press enter at the UI secreen, there is no login window but there is an option to restart etc bottom RHS. Pressing shift and restart here did not work. Shift and F8 does not work (option 4) and for option 3 I need to be logged in.... Any other ideas? Thanks!



#4 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,940 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 PM

Posted 23 March 2017 - 05:29 AM

Use the Shift + Restart combination. Another way of getting into Safe Mode in Windows 10 is to use the Shift + Restart combination. Open the Start menu and click or tap on the Power button. Then, while keeping the Shift key pressed, click or tap on Restart.

 

HERE


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy


#5 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 06:49 AM

When I use the windows installation media from my USB drive I get a number of options under troubleshoot, advanced. None of them worked.

 

Then I tried powering down on boot twice to enter the following options:

 

Roll back to previous build - it will not do that

Startup repair - windows could not load correctly, try system restore.

System restore - does not work (tried the 2 available restore points), message says, could not repair pc

Cmd prompt: Bcdedit /set {default} safeboot      Tried this and it gave me an error message

Startup settings pressed F4 to enable safe mode and nothing happened....


Edited by Suzze, 23 March 2017 - 06:50 AM.


#6 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 06:51 AM

I can't open the start menu as I cant log in. I tried shift and restart on the empty login screen but that didn't work either unfortunately...


Edited by Suzze, 23 March 2017 - 06:51 AM.


#7 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 07:17 AM

Actually Condobloke, from your link this worked: At the command prompt, enter these three lines, making sure to hit Enter at the end of each one:

  • c:
  • bcdedit /set {default} bootmenupolicy legacy
  • exit

Select Turn off your PC. Boot the computer and repeatedly press and release F8 until the Advanced Boot Options menu pops up. 

 

 

I am now in Advanced Boot options - yeah! BUT. My keyboard has been disabled???  I tried plugging it into different ports, but nothing (no light for caps lock or num lock). I can neither select an option nor escape?? Unbelievable....


Edited by Suzze, 23 March 2017 - 07:18 AM.


#8 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 07:29 AM

Wait tried another keyboard and it worked!! Now trying to access msconfig...



#9 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 07:58 AM

Hallelujah - success, I'm in! Thank you so so much for your help Condobloke!!!!!!  :bounce:



#10 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:59 AM

Posted 23 March 2017 - 08:01 AM

From Windows Recovery Environment open the Command Prompt and execute below commands one at time:


Ren  C:\windows\system32\config\SYSTEM      SYSTEM.BAK


Copy  C:\Windows\System32\config\RegBack\SYSTEM      C:\windows\system32\config

When computer boots into WinRE environment the drive letter assign to Windows partition may not be C: drive letter because Windows 7, 8 , 8.1 and 10 creates a separate system partition when it's installed from scratch. The system partition contains boot files WinRE assigns the system partition the C: drive letter and the Windows installed partition will be assign any other drive letter usually D: drive letter is assign to Windows installed partition. The Bcdedit /enum | find "osdevice" command can be use to find out the drive letter of the Windows installed partition the output of the Bcdedit command is similar to this osdevice partition=D:. The drive letter after partition= is the drive letter of the Windows partition.


Edited by FreeBooter, 23 March 2017 - 08:02 AM.

Posted Image


#11 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 08:15 AM

aha ok interesting, thank you FreeBooter :-)



#12 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:59 AM

Posted 23 March 2017 - 08:21 AM

I'm glad to hear you were able to resolve your issue!


Posted Image


#13 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,595 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:08:59 PM

Posted 23 March 2017 - 08:56 AM

When you accessed the System Configuration (msconfig) did you select the Services tab and change the settings back to their default settings?  Specifically did you remove the check from Hide all Microsoft services and click/tap on Enable all, then click/tap Apply, then OK?
 
If you did, did this resolve the issue?


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#14 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,940 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 PM

Posted 23 March 2017 - 01:24 PM

My Pleasure, Suzze !


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy


#15 Suzze

Suzze
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:59 AM

Posted 23 March 2017 - 03:06 PM

dc3 I think it was this that worked at cmd prompt

  • c:
  • bcdedit /set {default} bootmenupolicy legacy
  • exit

Once I was in advanced boot options I could start the pc in safe mode - previously I tried everything and wasn't getting anywhere except back to the blank login screen. However once I was in safe mode, I could login and then I did exactly what you outlined and restarted. Bob's your uncle :-)


Edited by Suzze, 24 March 2017 - 04:54 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users