Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

FUNCTION KEY MALFUNCTION


  • Please log in to reply
4 replies to this topic

#1 bearspencer

bearspencer

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:42 PM

Posted 17 March 2017 - 07:39 PM

FUNCTION KEY MALFUNCTION

 

After installing the latest Win10 update my laptop’s function key default has been set to “on” 

This makes writing for a living a hell of a lot harder than it already is, since the fn key has to be pressed and held with the space key before and after every word.

 

The laptop is a Toshiba Model L775D-S7226.

 

It was upgraded from Win 7 Business to Win10 Pro x64; but not from BIOS to UEFI.

 

Here’s what I’ve tried so far:

 

Entered both FN and Function into Windows Search without any results except web based ones (which seemed odd),

 

Pressing and holding FN with the below keys

alt

ctrl

delete

end

esc

home

ins

numLock

pgdown

pgup

shift

spacebar

Windows

 

Entered the BIOS, set it to revert to “default settings” and then re-booted.

 

 

SYSTEM INFO

 

Laptop: Toshiba Model L775D-S7226.

 

OS Version: Microsoft Windows 10 Pro, 64 bit

 

Processor: AMD A6-3400M APU with Radeon™ HD Graphics, AMD64 Family 18 Model 1 Stepping 0

 

Processor Count: 4

 

RAM: 5610 Mb

 

Graphics Card: AMD Radeon HD 6520G, 512 Mb

 

Hard Drives: C: 282 GB (63 GB Free);

 

Motherboard: PEGATRON CORPORATION, TKBSS

 

Antivirus: Windows Defender, Disabled; Panda Protection Enable



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,625 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:42 PM

Posted 17 March 2017 - 09:08 PM

Toshiba shows no drivers listed for Windows 10. See if you can install the Hotkey program for Windows 8.1. It may have a listing for disabling function keys. See Flash cards on this page.

 

http://support.toshiba.com/support/modelHome?freeText=3026073&osId=38



#3 bearspencer

bearspencer
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:42 PM

Posted 22 March 2017 - 05:17 PM

Thanks for helping.

DL/d and tried to install Toshiba Value Added Pack executable
A DOS/Command window rapidly opened and closed without any hints as to whether it installed or not.


DL/d Toshiba Function Key program; app gave regular pre and post announcements.
Opened program only to find it apparently only gives notifications for the Power Plan and Touch Pad settings,

Turned both Notification toggles to "On", re-booted and then tested by pressing the spacebar with and without pressing the fn key. Problem remained.

Tried turning to "Off" & still no change

 



#4 JohnC_21

JohnC_21

  • Members
  • 22,625 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:42 PM

Posted 22 March 2017 - 05:25 PM

I don't have any other ideas, sorry. You may find a solution in this Microsoft thread regarding Toshiba L775, hotkeys, and Windows 10.

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-update/toshiba-l775-laptop-fn-key-keyboard-issue-after/ef99bfc5-e7e5-4ed3-97df-4e4de3081fdb



#5 bearspencer

bearspencer
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:42 PM

Posted 30 March 2017 - 01:21 PM

Thanks. Appreciate your time and trouble.

 

I continued to search T's support and found a Toshiba Flash card utility. It Installed as "C:\Program Files\TOSHIBA\Hotkey\ButtonSupport\TouchpadED.exe"

 

When I ran the app, a message opened announcing the fn key had been switched off. The keyboard functioned as normally expected. Added it to Startup and its good to go; most of the time.

 

The keyboard occasionally reverts to the problematic version when I switch browsers (PaleMoon to Cyberfox and vice versa).

 

Even though this saves me the trouble of having to fn-spacebar 200x per hour, it seems an inelegant solution. Consequently I intend to try the options offered by the link you provided.

 

Thanks, again






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users