Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

2nd monitor HDMI blurry


  • Please log in to reply
7 replies to this topic

#1 cornflakes2

cornflakes2

  • Members
  • 228 posts
  • OFFLINE
  •  
  • Local time:12:37 AM

Posted 15 March 2017 - 08:08 PM

So I set up my new computer and the main monitor which is connected via a serial/DVI port to my Geforce 1070 GTX card looks fine, but when I hooked up my 2nd monitor to one of the HDMI ports in the graphics card, the texts look blurry.    I tried adjusting the monitor settings (sharpness) and I tried truetype but still looks blurry.

 

I believe it has something to do with HDMI. I had this issue on previous computers whenever connecting via HDMI, but as soon as I connected it to a VGA/DVI port, it looked fine.  The only problem is on this graphics card (GeForce 1070 GTX by MSI), it only has 1 DVI port and the rest are HDMI ports (5 i think).  

 

Any solutions on how to correct the blurry issue?

 

Thanks



BC AdBot (Login to Remove)

 


#2 jonuk76

jonuk76

  • Members
  • 2,136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:03:37 PM

Posted 15 March 2017 - 10:05 PM

What sort of monitors do you have?  I would suggest these things to try as a starting point...

 

In Windows settings, check the resolution output to the second monitor matches the monitors native resolution

Also in Windows settings, check scaling on that monitor is set to 100%

If the second monitor is actually a TV, ensure no aspect ratio scaling is being done by the TV (e.g rescaling the input for a 16:9 AR).  A giveaway of this happening might be the edges of the desktop are cut off.


7sbvuf-6.png


#3 cornflakes2

cornflakes2
  • Topic Starter

  • Members
  • 228 posts
  • OFFLINE
  •  
  • Local time:12:37 AM

Posted 16 March 2017 - 09:30 AM

Both monitors are computer monitors (24 inch) Samsung S24D300 and SyncMaster 2494 HSI.  I've used both on the old PC which was connected via DVI and VGA and both worked fine with no blurriness.  The monitor (S24D3000) is connected on my new pc via DVI and the SyncMaster one is connected via HDMI cable but that's where it's blurry (the text).

 

If I switch monitors then the S24D300 will now become blurry and the SyncMaster will be clear as normal.  

 

Where can I check scaling?  The resolution on both monitors are set on their native (1920x1080) and 60Hz.



#4 jonuk76

jonuk76

  • Members
  • 2,136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:03:37 PM

Posted 17 March 2017 - 12:44 PM

You'll probably find some of the outputs are DisplayPort rather than HDMI.  As far as I can tell, most GTX1070's have no analogue video output, just DVI-D, HDMI and DisplayPort outputs.  This means anyone with a VGA only monitor would need an active digital to analogue converter.

 

Scaling in Windows 10 is in Settings > Display and it's a sliding scroll bar, labelled "Change the size of text, apps and other items".  I have found on some displays, some scaling settings (e.g 125%) produce very unsatisfactory text quality...

 

A8YwhO6.png

 

It's interesting because HDMI video output is essentially the same as DVI (you can convert a HDMI output to DVI-D, obviously without sound, with a passive adaptor or cable) so there's no inherent reason why HDMI should be a problem.  That would be my next suggestion if you are still having problems - try using a HDMI to DVI cable.


Edited by jonuk76, 17 March 2017 - 12:58 PM.

7sbvuf-6.png


#5 cornflakes2

cornflakes2
  • Topic Starter

  • Members
  • 228 posts
  • OFFLINE
  •  
  • Local time:12:37 AM

Posted 18 March 2017 - 04:45 AM

Thanks! Yes I checked scaling and it is already set to 100%.

Interestingly, when I come back from sleep mode, my 2nd monitor will have a message on it saying "not optimum mode recommended mode 1920x1080 60 hertz"

but AFAIK my 2nd monitor is set to 1920x1080 60 hertz when I open the Nvidia control panel and set the settings on the 2nd monitor there.

 

Yes, I think I will have to try that hdmi to dvi adapter. 



#6 jonuk76

jonuk76

  • Members
  • 2,136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:03:37 PM

Posted 18 March 2017 - 06:21 AM

What resolution is the monitor detecting?  It might be shown in the monitor menu somewhere..

 

Is the 1920 x 1080 resolution also showing for both monitors in Advanced Display Settings (a sub page in the Display Settings dialog).

 

URwfCws.png

 

On my own monitor I was just messing about with it (it's an LG so probably quite different to what's on your Samsungs), and found some settings there that affected text quality, including things like overscan and "super resolution" (which seemed to be another method of setting sharpness). It should work best with no overscan.


7sbvuf-6.png


#7 cornflakes2

cornflakes2
  • Topic Starter

  • Members
  • 228 posts
  • OFFLINE
  •  
  • Local time:12:37 AM

Posted 22 March 2017 - 06:45 AM

I bought a HDMI - DVI adapter and plugged it in my monitor but there was no signal.  So that option doesn't seem to provide any solution.

Gosh, I don't know what to do about this blurry screen.  I'll keep tinkering with it and see if i can find any of your suggested settings but this samsung monitor doesn't have overscan or super resolution options that I could find....



#8 cornflakes2

cornflakes2
  • Topic Starter

  • Members
  • 228 posts
  • OFFLINE
  •  
  • Local time:12:37 AM

Posted 25 March 2017 - 12:11 AM

Well, I tinkered with the settings and found something called "image size" and it was set at "wide" and I changed it to "auto" and I also found something called AV and changed it from ON to OFF.  It seems to have done the trick!  My eyes don't feel irritated and it doesn't look blurry like before.  When I comeback from sleep mode, my 2nd monitor will stay say that my monitor is not at optimum setting even though in the settings it is 1920x1080 60Hz....so that I'm not still sure why I get that message.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users