Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable To Print


  • Please log in to reply
9 replies to this topic

#1 joebeaven

joebeaven

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 10 March 2017 - 03:41 AM

Hi,

 

I've just done a fresh install of Windows 10 which went well except that I'm unable to print. I've installed both my printers with Windows 10 drivers and both show up under Settings => Devices, but when I try to print from any program, I get this error:

 

"Before you can print, you need to select a printer.

If you need to install a printer, either double-click the Add Printer icon or click the Find Printer... button located on the General tab of this dialog."
 
When I click on "Find Printer..." I get taken to the Network folder which just contains a folder called DESKTOP which is empty.
 
Please can someone tell me how to fix the problem?
 
Thanks,
Joe


BC AdBot (Login to Remove)

 


#2 landscaper

landscaper

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Local time:02:39 PM

Posted 10 March 2017 - 07:19 AM

Is it safe to assume you went into devices and printers and marked your printer as default.



#3 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 10 March 2017 - 10:29 AM

No, how do I do that?



#4 landscaper

landscaper

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Local time:02:39 PM

Posted 10 March 2017 - 04:36 PM

Open up the control panel and click on devices and printers.You should then see yours listed.Right click on it and check off set this

printer as default.That should work.



#5 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 11 March 2017 - 03:03 AM

I don't get that as an option. Here's what I see:

 

JJCKgBZ.jpg



#6 landscaper

landscaper

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Local time:02:39 PM

Posted 11 March 2017 - 07:11 AM

Sorry,I am at a loss now.Are you sure your printer is installed correctly.If it is,someone else here will have to help you.



#7 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 11 March 2017 - 07:41 AM

When trying to print from a different program, I got this error message:

 

"The local print spooler service is not running. Please restart the spooler or restart the machine"

 

I turned the print spooler on through Services.msc which allow me to print with some programs, but not others. Is there a way to set print spooler to run on startup?



#8 landscaper

landscaper

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Local time:02:39 PM

Posted 11 March 2017 - 07:49 AM

Usually if you go into services and click on print spooler it gives you the option to set it on automatic.After you do that restart it and it should work.You still have to check off your default printer.



#9 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 11 March 2017 - 07:51 AM

I've done that and restarted and now it's working fine. Thank you for your help.



#10 landscaper

landscaper

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Local time:02:39 PM

Posted 11 March 2017 - 08:22 AM

You are welcome






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users