Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Zorin os 12 changing time in Windows 7 and the bios


  • Please log in to reply
14 replies to this topic

#1 placemat

placemat

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 08 March 2017 - 04:01 AM

Hi Everyone, I was wondering if someone could tell me why everytime I plug in my external harddrive with Zorin os 12 installed on it, it changes the time in the bios

Asus A85XM-A and Windows 7 time. If I unplug the external harddrive for a few days, and just use Windows 7, the time stays correct in the bios and in Windows.

Is there some little correction I can make in Zorin? Any help would be appreciated.



BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:27 PM

Posted 08 March 2017 - 06:39 AM

Hi,

Please boot up with Zorin, open a terminal then run the following command:
cat /etc/default/rcS
(I suggest using copy and paste, to copy the command from my post and paste it in your terminal, to remove the potential for typing errors)

Please paste the output of the command into your next post.

#3 Mike_Walsh

Mike_Walsh

    Bleepin' 'Puppy' nut..!!


  • Members
  • 1,283 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:King's Lynn, UK
  • Local time:06:27 PM

Posted 08 March 2017 - 06:42 AM

Hi, placemat.

 

I should perhaps keep away from this, since I can't give you instructions for how to actually perform the necessary 'fix' (it's a looong time since I used that OS, or indeed even dual-booted with any form of Windows).....but I can tell you why it's happening.

 

It's all to do with the difference in the way that Windows and Linux, respectively, handle the 'time zone' thing. Linux systems synchronize with GMT; Windows, instead, likes to synchronize with what it calls 'local' time.....which, depending on where in the world you are, can of course be a long way off GMT.

 

As I understand it, there's two ways around this. You can either perform a Windows registry 'hack' to force it to use GMT instead.....or (which is probably miles easier), just tell Linux to use 'local' time instead.

 

Now all you need to do is wait for those with more knowledge of the 'nuts'n'bolts' than me to offer their advice as to how you actually do this. Since I run Linux exclusively, I don't, personally, have this problem.

 

 

Mike.  :wink:

 

EDIT:- Al obviously posted at the same time as me. He'll put you right.


Edited by Mike_Walsh, 08 March 2017 - 06:44 AM.

Distros:- Multiple 'Puppies'..... and Anti-X 16.1

My Puppy BLOG ~~~  My Puppy PACKAGES

Compaq Presario SR1916UK; Athlon64 X2 3800+, 3 GB RAM, WD 500GB Caviar 'Blue', 32GB Kingspec PATA SSD, 3 TB Seagate 'Expansion' external HDD, ATI Radeon Xpress 200 graphics, Dell 15.1" pNp monitor (1024 x 768), TP-Link PCI-e USB 3.0 card, Logitech c920 HD Pro webcam, self-powered 7-port USB 2.0 hub

Dell Inspiron 1100; 2.6 GHz 400FSB P4, 1.5 GB RAM, 64GB KingSpec IDE SSD, Intel 'Extreme' graphics, 1 TB Seagate 'Expansion' external HDD, M$ HD-3000 'Lifecam'.

 

KXhaWqy.gifFQ8nrJ3.gif

 

 


#4 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 08 March 2017 - 07:33 AM

# /etc/default/rcS
#
# Default settings for the scripts in /etc/rcS.d/
#
# For information about these variables see the rcS(5) manual page.
#
# This file belongs to the "initscripts" package.

# delete files in /tmp during boot older than x days.
# '0' means always, -1 or 'infinite' disables the feature
#TMPTIME=0

# spawn sulogin during boot, continue normal boot if not used in 30 seconds
#SULOGIN=no

# do not allow users to log in until the boot has completed
#DELAYLOGIN=no

# be more verbose during the boot process
#VERBOSE=no

# automatically repair filesystems with inconsistencies during boot
#FSCKFIX=no

Thank you both for replying.



#5 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:27 PM

Posted 08 March 2017 - 08:24 AM

Thanks for that, however the info I was looking for isn't there.

Please run this command in a terminal and post the output; the info re time zones should be here:
timedatectl


#6 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 2,793 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:01:27 PM

Posted 08 March 2017 - 09:41 AM

This is a common problem with a linux/ windows dual boot as windows and linux read time differently.

 

Read this as it should help you as Zorin is based on Ubuntu:

 

http://askubuntu.com/questions/800914/clock-shows-wrong-time-after-switching-from-ubuntu-to-windows-10


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#7 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 08 March 2017 - 04:06 PM

Thank you both for replying, and I will look at the above article. I have typed below the results, for some reason it would not paste.

Local Time Thurs 2017-03-09 07:58:23 AEDT

Universal Time Thurs 2017-03-08 20:58:23 UTC

RTC Time Wed 2017-03-08 20:58:22

Time Zone Australia/Sydney (AEDT,+ 1100)

Network Time on Yes

NTP Synchronised Yes

RTC in Local Time No



#8 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:27 PM

Posted 09 March 2017 - 10:48 AM

If that is the correct time zone, it might be worth trying disabling network synchronisation, to see if that does the trick. To disable network synchronisation:
timedatectl set-ntp 0
To see if that worked, boot into Windows, fix the time, boot into Zorin then reboot into Windows again.

If that didn't do the trick, or if it caused any other issues, enable network synchronisation again by swapping 0 for 1 in the above command:
timedatectl set-ntp 1


#9 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 09 March 2017 - 04:07 PM

Hello AI1000, and thank you for replying again. I have tried both of the above commands, but the response I keep getting is

no command found

did you mean command timedatect1 from package systemd (main)

The time zone is correct for where I live :bananas:



#10 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 2,793 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:01:27 PM

Posted 09 March 2017 - 08:10 PM

That is a letter L not a number 1

 

lowercase L


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#11 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 10 March 2017 - 05:01 AM

Hello again, I realized I typed above a number 1 instead of the letter L. I have tried both commands, with the letter L, and nothing has changed. It still is changing the bios time, and windows time,

and I am not prepared to change windows time because I know it keeps the right time. Do not know what to do, but thank you everyone for continuing to try to help me. :bananas:



#12 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 11 March 2017 - 06:31 AM

Hello Everyone, I have found an answer to my problem that is working so far. I had a look in the Date and Time Settings

Automatic Date and Time were turned on

Automatic Time Zone was also on

I have turned both off, and have booted into Windows 7 a few times, and the time is still correct. Also looked in the bios, and it also has the correct time. I will keep fingers crossed that this keeps

working. :bananas:



#13 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 2,793 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:01:27 PM

Posted 11 March 2017 - 07:49 AM

It should stick once its in there.

Though you may have to invoke sudo next round elevating your permissions temporarily to get it to stick

 

sudo timedatectl set-ntp 0

 

that would bve your command


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#14 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:05:27 AM

Posted 11 March 2017 - 04:25 PM

Hello MadmanRB, Thank you for replying. It does seeming to be sticking. If not I will use the above sudo command. Thank you everyone

#15 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:27 PM

Posted 13 March 2017 - 01:09 PM

Pleased to hear you found a solution.

Thanks for letting us know what it is. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users