Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 Disk almost always at 100%


  • Please log in to reply
8 replies to this topic

#1 cartotech81

cartotech81

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 01 March 2017 - 09:25 PM

I have an alienware 17 r4 that is about 4 months old. Lately it seems like my disk is always running at 100%. On top of that it seems like games on Steam and battle.net become corrupt often and I have to reinstall or repair the game files. I have ran chkdsk and it comes back with everything fine.

 



BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:22 PM

Posted 02 March 2017 - 07:36 AM

What do you mean your disk is running at 100%? Do you mean the disk is full or the cpu is running at 100%? Please explain in detail.



#3 cartotech81

cartotech81
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 02 March 2017 - 07:41 PM

Correct. I go into task manager and it shows disk is 100%. CPU is generally around 12% and memory around 60%.


Edited by cartotech81, 02 March 2017 - 07:41 PM.


#4 pahra_123

pahra_123

  • Banned
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 AM

Posted 03 March 2017 - 04:45 AM

MSI mode can be disabled for specific devices via the registry:

 

  1. Identify if you are running the inbox AHCI driver (StorAHCI.sys):
    1. Open a command prompt with administrator privileges. Then type the following command in the command prompt window and hit Enter: devmgmt.msc
    2. Under IDE ATA/ATAPI Controllers right-click on the AHCI controller node and select Properties. This node is usually called “Standard SATA AHCI Controller.”
    3. Navigate to the driver tab and click Driver Details.
    4. If you see “StorAHCI.sys” in the list, you are running the inbox driver.

Edited by Chris Cosgrove, 03 March 2017 - 05:44 PM.


#5 Platypus

Platypus

  • Global Moderator
  • 15,181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:09:22 AM

Posted 03 March 2017 - 05:56 AM

The correct source with complete instructions for the above partial suggestion is:

 

https://support.microsoft.com/en-au/help/3083595/task-manager-might-show-100-disk-utilization-on-windows-10-devices-with-message-signaled-interrupt-msi-mode-enabled


Edited by Platypus, 03 March 2017 - 05:58 AM.

Top 5 things that never get done:

1.

#6 cartotech81

cartotech81
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 03 March 2017 - 08:41 PM

 

MSI mode can be disabled for specific devices via the registry:

 

  1. Identify if you are running the inbox AHCI driver (StorAHCI.sys):
    1. Open a command prompt with administrator privileges. Then type the following command in the command prompt window and hit Enter: devmgmt.msc
    2. Under IDE ATA/ATAPI Controllers right-click on the AHCI controller node and select Properties. This node is usually called “Standard SATA AHCI Controller.”
    3. Navigate to the driver tab and click Driver Details.
    4. If you see “StorAHCI.sys” in the list, you are running the inbox driver.

 

 

I done have anything that says IDE ATA/ATAPI Controllers in the device manager. I opened everything in the tree and it didnt mention ATA or ATAPI anywhere. Closest thing to that was ACPI.



#7 cartotech81

cartotech81
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 27 March 2017 - 03:47 PM

This is a screenshot of my system, with the Disk being at 100%.



#8 JohnC_21

JohnC_21

  • Members
  • 24,437 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:22 PM

Posted 27 March 2017 - 04:10 PM

I don't see a screenshot but see if disabling fast startup helps. After disabling fast startup open a command prompt and type

 

shutdown -s  

 

To complete a full shutdown then reboot.



#9 cartotech81

cartotech81
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 27 March 2017 - 05:19 PM

When I was in the post message I clicked to add a file and chose a screenshot, but not sure why it didnt show after posting.

 

I tried disabling fast startup and restarted computer via command prompt as directed. After startup it was still running around 100%, but was hitting mostly around 98%. Right now it is at 4% so it may be working good. Ill keep an eye on it and post back if it changes.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users