Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Linux Mint time of 1:32 PM today Feb 27 is 6:33 PM in Windows


  • Please log in to reply
4 replies to this topic

#1 cmptrgy

cmptrgy

  • Members
  • 1,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:10:31 AM

Posted 27 February 2017 - 03:56 PM

The Linux Mint time of 1:32 PM today Feb 27 is 6:33 PM in Windows

 

When I correct the time in Windows, the correct time holds.

--- When I go over to Linux Mint, the time is correct: no correction needed.

--- But when I go back to Windows, the time changes by 5 hours as noted above.

This just started happening once I set up Windows 10 & Linux Mint as a dual boot system.

--- I never had a problem with Windows 10 time before.

 

My Windows 10 settings are

Time zone (UTC -5.00) Eastern Time US & Canada

--- Set time automatically

--- Set time zone automatically

 

I do not know what the Linux Mint settings are as I do not know how to look that up.

 

How can I fix the time so both Windows 10 & Linux Mint maintain the correct time all of the time?



BC AdBot (Login to Remove)

 


#2 bumping

bumping

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:08:31 AM

Posted 27 February 2017 - 06:05 PM

I'm a differ configuration, so this may/may not be useful

(am Disk swapping latest Cinnamon and Win7)

 

Unplug the LM drive, it's always got the right time

But unplug the Win7 drive, it's always wrong.

 

 

GUESSING,

LM the date time settings (click the date/time in lower right GUI)

Then at bottom click "Date and Time Settings"

 

Has option at top, "Network Time" switch to "On", so it corrects itself upon boot.

 

Win *may* have such a feature, buried somewhere

(haven't looked in Win7 and I don't have 10)


Edited by bumping, 27 February 2017 - 06:17 PM.


#3 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,015 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:10:31 AM

Posted 28 February 2017 - 05:43 AM

cmptrgy, here's the page with the details on how to fix this issue, have used with success many times. :)

 

http://www.webupd8.org/2014/09/dual-boot-fix-time-differences-between.html

 

Go slow & read carefully, fix on Linux Mint first, then download the linked registry file for Windows, you are able from Linux Mint to drop the file in your Downloads folder within Windows by selecting Computer & will then see the partition, or can bookmark & download from Windows, whichever you want to do. The Web page is updated as needed to reflect newer editions of Ubuntu, which Linux Mint is built upon. 

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#4 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,051 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:10:31 AM

Posted 28 February 2017 - 09:13 AM

Indeed this is a common problem with dual booting.

Linux and windows read time differently so they can clash on what time it is


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#5 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,015 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:10:31 AM

Posted 01 March 2017 - 02:54 AM

MadmanRB, you're right, though it wasn't always this way. :)

 

Seems to be an issue that came up in the last few years, I recall when dual booting XP/W2K & Linux Mint, and there were no issues. Now even the UEFI or BIOS reports Linux time zone unless corrected. :(

 

Of course, this can be a fat pain in the rear when updating a Windows OS & the time throws off some of the OS functions, until one applies the fix & reboot, or manually fiddling with the Internet Time every times Windows is booted in to make things work as normal, until next boot. It has to be Linux reporting the wrong time zone to the UEFI or BIOS on pre-2012 computers, no other explanation for the action. At some stage, someone 'fixed' something that wasn't broken, though as I linked above, easily fixed. :lol:

 

Cat                                                                                                                                                                                                                


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users