Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

security certificate can't be verified. Update certificates on my PC


  • Please log in to reply
5 replies to this topic

#1 NotionCommotion

NotionCommotion

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Local time:11:13 AM

Posted 25 February 2017 - 04:40 PM

Just replaced my hard drive, installed Windows 10 off of an iso, and installed Outlook 2007 off of a DVD. I am now setting up an Outlook email account with Comcast:
 
Comcast told me to set it up as:
  • Type: IMAP
  • Incoming Mail Server: imap.comcast.net SSL encrypted Port 995
  • Outgoing Mail Server: smtp.comcast.net TTL encrypted Port 587
  • Enable Secure Password Authentication (SPA)
Upon doing so, I get the following popup:
The server you are connected to is using a security certificate that cannot be verified.
The target principal name is incorrect.
Do you want to continue using this server?
Yes No
 
I clicked yes but am getting the following error:
Send test e-mail message: Cannot send the message. Verify the e-mail address in your account properties. The server responded: 550 5.1.0 Authentication required
I have another PC which is working.  Its settings are as follows.  I used them on the new PC, but am still getting the error.
  1. Type: POP3
  2. Incoming Mail Server: mail.comcast.net SSL encrypted Port 995
  3. Outgoing Mail Server: smtp.comcast.net SSL encrypted Port 465
  4. Disabled Secure Password Authentication (SPA)
I think the problem is my hard drive doesn't have current public certificates on it but old ones. Is there a way to force my PC to update its certificates?  What causes this error and how can I fix it?
 
Thank you

Edited by NotionCommotion, 26 February 2017 - 09:01 AM.


BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,016 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:05:13 PM

Posted 26 February 2017 - 06:40 PM

This problem is often connected with a dead or dying CMOS battery. Is your computer showing the correct time and date ?. If there are errors with the time and date then this is a good indicator of a CMOS battery problem.

 

If the time and date are wrong you could try correcting them and then trying to get to your web-sites.  A problem with laptops is that replacng a CMOS battery varies from ridiculously easy to plain ridiculous. A Toshiba Satellite I was working on this afternoon - one screw and the hard drive, RAM and CMOS battery cover pops off. An older E-machines computer I had the same problem with about a year ago required a full teardown - to change a battery costing 50 pence. The best way to find out what is involved is to search on YouTube for 'Your make and model' + 'CMOS battery'.

 

Chris Cosgrove



#3 NotionCommotion

NotionCommotion
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Local time:11:13 AM

Posted 26 February 2017 - 09:06 PM

Thank you for your reply Chris, but I wonder if you meant to reply to another post?  CMOS batter can cause problems with certificates?  Please confirm before I go down this rabbit hole.  Thanks



#4 opera

opera

  • Members
  • 1,018 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:05:13 PM

Posted 27 February 2017 - 01:24 AM

Incorrect system time can cause many problems. One of the causes of system time falling behind is a failing CMOS battery.

 

First check your system time is correct and set fo country/area of world you are in.

 

https://askleo.com/why-am-i-getting-security-certificate-errors/

 

First, check your computer’s clock, the one that appears on your screen. Make certain that the year, date, time, time zone and daylight saving time (or “summer time”) settings are all set correctly.

When your computer checks the accuracy of a certificate part of that involves the current time. If your  clock is off, then your machine may assume that  there’s something wrong with the certificate. If the clock is off, every https certificate in the world might look broken when you access it.



#5 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,016 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:05:13 PM

Posted 27 February 2017 - 05:17 PM

Sorry for the inadequate explanation, I had had a long day yesterday.

 

As Opera has explained, if the date/time on your system is incorrect it can lead to the rejection of every certificate. An error of a few minutes is neither here nor there but, if I remember rightly, a certificate has a life of six months and then must be renewed. The most frustrating case I ran into was on my sister-in-law's desktop. The time was showing exactly correctly. Two hours later I checked the date, that was out by eight years !  One new CR2032 battery and the problem was resolved.

 

Chris Cosgrove



#6 NotionCommotion

NotionCommotion
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Local time:11:13 AM

Posted 27 February 2017 - 09:49 PM

Thanks Chris and Opera,

 

Sorry you had a long day yesterday Opera.  Yeah, I had one of those today!

 

Good news is the problem magically went away.  I don't think time was the issue as it appeared to be correct all the time. I suspect (but don't know for sure) that being a new PC, I had stale local certificates.  I have no idea if this makes any sense, so forgive me if it doesn't, but at least I now have email!

 

Thanks for your help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users