Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cross Browser Help & Color Help


  • Please log in to reply
12 replies to this topic

#1 Yourhighness

Yourhighness

    The BSG Malware Fighter


  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 02 September 2006 - 11:22 AM

Hi guys,

I ve gotten myself a domain these days and decided to work on my test page that I left off with 9 month ago. Now I just realised that my website shows totally different in IE and in FF.

In Firefox the colors show correctly, but my 3 column layout doesnt finish off correctly as it should.
In Internet Explorer it shows the 3 column layout correctly, but the colors dont. Now I did do a bit of a search on "cross browser compatability", but didnt really find anything that described what I could do about that. :thumbsup:

This is my CSS file:
http://mytidbits.de/css/master.css and this is how it looks on

FF:
http://www.mytidbits.de/docs/mytidbits/ffcolor.png

and

http://www.mytidbits.de/docs/mytidbits/fffooter.png

IE:
http://www.mytidbits.de/docs/mytidbits/iecolor.png

and

http://www.mytidbits.de/docs/mytidbits/iefooter.png

I would appreciate if anyone could guide me into what it could be that makes it display that oddly and thanks in advance.

rgds,

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


BC AdBot (Login to Remove)

 


m

#2 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 05 September 2006 - 12:01 AM

* up * no one an idea? :thumbsup:

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#3 ColdinCbus

ColdinCbus

  • Members
  • 312 posts
  • OFFLINE
  •  
  • Local time:06:12 PM

Posted 05 September 2006 - 07:41 PM

try
#top
{
 	padding: .5em;
	background-color: #194264; 
	background-image: url(/img/Tidbits.gif);
	background-repeat: no-repeat; 
	background-position: center;
	border-bottom: 1px solid #194264;
}

Edited by ColdinCbus, 05 September 2006 - 07:41 PM.


#4 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 06 September 2006 - 11:33 AM

ColdinCbus!

You are my hero. I couldnt quite see what you did to make the colors work, but I THANK YOU! Now if you or anyone else has an idea how it comes that this displays weird:

FF:
Posted Image

IE:
Posted Image

Its weird that the light blue shows in FF under the white area and not under IE :thumbsup:
Cheers and Thank you!

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#5 ColdinCbus

ColdinCbus

  • Members
  • 312 posts
  • OFFLINE
  •  
  • Local time:06:12 PM

Posted 07 September 2006 - 08:02 AM

In your stylesheet, check where you are setting the background properties. You to use the following instead of using just background:

background-color
background-image
background-repeat
background-position
background-attachment

Do you want that blue line there or not?

Edit = now that I look at it, I think it is your google script that is too long and is pushing the footer down in firefox. If you resize the browser window so the text is pushed down to where the google script ends, that line goes away in firefox. You can try and add a few <br /> after the text until that line goes away. That should work. I think FF may be picking up some kind of imbeded table padding from the google script.

Edited by ColdinCbus, 07 September 2006 - 08:31 AM.


#6 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 07 September 2006 - 08:08 AM

Hi there,

thanks for the explanation. Will bare in mind for future. I dont want the blue bar to show. I wanted it as a clear three column layout with footer and header. I hope this helps and thanks alot for your quick response :thumbsup: :flowers:

cheers,

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#7 ColdinCbus

ColdinCbus

  • Members
  • 312 posts
  • OFFLINE
  •  
  • Local time:06:12 PM

Posted 07 September 2006 - 08:33 AM

See my edit above. I think it is the google script causing that. :thumbsup:

#8 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 08 September 2006 - 12:45 PM

Edit = now that I look at it, I think it is your google script that is too long and is pushing the footer down in firefox. If you resize the browser window so the text is pushed down to where the google script ends, that line goes away in firefox. You can try and add a few <br /> after the text until that line goes away. That should work. I think FF may be picking up some kind of imbeded table padding from the google script.


You just plain ROCK!
:thumbsup: :flowers: :D Me sily bleepin german had a min height of 560 in the center div and 600 left n right. It couldn really work properly.

*Grinler shouts you a nice german beer for that great help Posted Image

Ty,

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#9 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 15 September 2006 - 11:54 AM

Hey there,

lol now I got two new problems:
1 ) Posted Image

2 ) Posted Image

(both thumbnail images). For the first one, I entered p and br tags as you suggested earlier. In IE it dont matter and still shows above. In FF I have neither 1, nor 2 occuring :thumbsup:

Thanks for any idea in advance.

rgds Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#10 ColdinCbus

ColdinCbus

  • Members
  • 312 posts
  • OFFLINE
  •  
  • Local time:06:12 PM

Posted 15 September 2006 - 12:59 PM

I am not seeing that issue in IE on my machine. What page does that occur on?

#11 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 15 September 2006 - 01:00 PM

I am not seeing that issue in IE on my machine. What page does that occur on?

Hey there thanks for quick response. Following two pages in IE:

http://www.mytidbits.de/disc.html
http://www.mytidbits.de/hijackthis.html

Thanks again.

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image


#12 ColdinCbus

ColdinCbus

  • Members
  • 312 posts
  • OFFLINE
  •  
  • Local time:06:12 PM

Posted 15 September 2006 - 08:29 PM

Other than missing images, I am not seeing that issue in IE on those pages.

#13 Yourhighness

Yourhighness

    The BSG Malware Fighter

  • Topic Starter

  • Malware Response Team
  • 7,943 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamburg
  • Local time:11:12 PM

Posted 16 September 2006 - 01:27 AM

Hi ColdinCbus,

thanks for the info. I didnt realise that I hadnt changed it yet. Pictures are now visible. Weird though that from my work machine and my home machine those two sites stuff up on IE? No idea what it could be.

Thanks for all the help. very much appreciated.

rgds.

Johannes

"How did I get infected?" - "Safe-hex" - Member of UNITE -
Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users