Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Connected, but no Internet...


  • Please log in to reply
3 replies to this topic

#1 whereangelsplay

whereangelsplay

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:02:31 AM

Posted 19 February 2017 - 07:16 PM

Hi all!

 

I've just come back to work (abroad) after being back in the UK for 4 weeks, and suddenly I have this problem. I've tried in three different places now  (using both ethernet and wireless connections) and I'm getting the same message: it's connected, but there's no Internet. When I run the troublershooter it finds two potential problems:

 

1) "Windows can't communicate with the device or resource (primarily DNS server)

 

2) "Security or firewall settings might be blocking the connection"

 

Sorry if there's an easy solution, which I imagine there is, but I'm a total technophobe and I couldn't find any solution after browsing here. Any help would be very gratefully received!



BC AdBot (Login to Remove)

 


#2 whereangelsplay

whereangelsplay
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Local time:02:31 AM

Posted 19 February 2017 - 07:19 PM

Sorry, on double-checking I'm not totally sure it's connected. But it definitely says "no Internet access".



#3 Illustrious

Illustrious

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:31 PM

Posted 19 February 2017 - 11:23 PM

Are you connecting to your router or the router of your internet company?
If connecting wirelessly, are you using any adapters? (netgear, etc)

Have you tried resetting your router/computer?

When you set your internet connection, are you setting it to home network?

 

It is possible your firewall could be falsly seeing your router as something harmful, and it denying it access, I would say try disabling your firewall and retrying the connection, however that is a risk you should balance out yourself.

When you open your Network and Sharing Center (assuming you are on windows), when you view the top area, does it have connections from (computer) ----- Multiple networks ----- Internet? If internet is red, then you are connecting to a network and not the internet, which is what you explained above.

One more thing, if you can find the option under Network and Sharing Center labeled "Internet Properties", click that, go to the "Connections" tab, and be sure you're connected in there.

I'm not qualified in this field, and am also not sure if I'm even qualified to offer help on this website. Best of luck with you.


𝑅𝑒𝑔𝒶𝓇𝒹𝓈, 𝐼𝓁𝓁𝓊𝓈𝓉𝓇𝒾𝑜𝓊𝓈


#4 iMacg3

iMacg3

    Bleepin' 68000


  • Malware Study Hall Senior
  • 1,064 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Indiana, USA
  • Local time:10:31 PM

Posted 21 February 2017 - 04:46 PM

Try checking if your connection is set to a static IP address. If so, turn it to "Assigned to DHCP." I had the same problem a while ago and that fixed it immediately.

If that doesn't help, try "flushing" the DNS. Press the windows key and R, type "cmd" in the run box without the quotes, and the type "ipconfig /flushdns" without the quotes. Then restart the computer.


Regards, iMacg3

"Do, or do not. There is no try." - Yoda




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users