Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Gimp toolbox disappears


  • Please log in to reply
9 replies to this topic

#1 ranchhand_

ranchhand_

  • Members
  • 1,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:06:16 AM

Posted 19 February 2017 - 06:58 PM

Longtime Photoshop user, I started using Gimp on a project just to get some experience with it. All is going really well, I like it as much as Photoshop. Suddenly I have an irritating problem that I would appreciate some help with, as follows:

I have the single screen open, working on a project. All is well. I click on the image using a selected tool out of the toolbox, and all open toolboxes default behind the working screen to the desktop. To get them back I must go to my Windows taskbar and use the mouse to select them individually to get them to open.  I select another tool to continue, and the instant I click in the picture all the toolboxes "hide" behind the Gimp screen. Needless to say, this gets irritating very fast and cuts down my work time a lot. This is the default now for every tool window.

When I boot Gimp now, no toolboxes are appearing, just the blank working window. All toolboxes are hidden behind the screen, but are running.

This sudden problem is acting like I accidentally "Cntrl/lettered" some keyboard combination and now the default is to hide all toolboxes. The toolboxes are still running...they all just default behind the Gimp screen and I must bring each one forward to use it (rather like moving layers to active/passive, if you know what I mean).

I have Googled this for an hour, and tried all the suggestions offered, such as:

> Windows tab >Dockable Dialogs

>Windows tab >Recently Closed Docks

>Windows tab >Toolbox, Toolbox options

>Windows tab> Hide Docks (off and on, no change)

 

At This point I am ready to reinstall Gimp (no big deal) but I thought I would try to find out what I did so I don't do it again. :)

Thanks

 


Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


BC AdBot (Login to Remove)

 


#2 eth4n

eth4n

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:16 PM

Posted 20 February 2017 - 11:25 AM

Interesting. As far as I know there's no such shortcut.

 

Have you tried enabling and disabling Window > Single-Window Mode? Also you could try Edit > Preferences > Window Management > Reset Saved Window Positions to Default Values.


Regards,

Ethan

 

If I don't reply within 48 hours, feel free to PM me.


#3 ranchhand_

ranchhand_
  • Topic Starter

  • Members
  • 1,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:06:16 AM

Posted 20 February 2017 - 01:09 PM

Thanks mucho for the comeback. At least that tells me that I may have a glitch or file corruption. Yes, I tried both of those options a couple of times. I had CorelDraw crash a couple of times before this, so maybe that was a contributing factor. Then I suspicioned that maybe my problem was actually an option so that if someone was using one tool for hours, he could clear the other toolboxes temporarily so the entire screen was clear except for the image he was working on.

I guess the best thing is just to reinstall Gimp.

Thanks again!

 

[EDIT]: Ok, weird time. I uninstalled Gimp using Control Panel/Remove Programs. Made sure there were no "footprints" left over in Explore. Re-downloaded Gimp from Gimp.org website (73.9 MB download). Installed Gimp 2.8.20.0 / . On first boot, it did the same thing.

OK......Deleted Gimp again, and this time used my trusty registry editor utility to remove all Gimp register entries (26 if I remember right). Re-downloaded and reinstalled Gimp. Opened it, and the same thing happened.

If anybody has any insights, you are welcome to post in.

 

[EDIT#2]:  Well, maybe I have a work around. I selected single window mode, and the docks jumped into view on either side of the work screen and do not disappear when I click in the screen. However, now they are not moveable, but permanently positioned. That gave me an idea, so I disabled single window mode, and manually positioned each dock at each side, but then re-sized the work screen between them, so actually they are not directly in the work screen. Now they do not default underneath the screen because they are not in it.

At least it is a work around. I still don't have an answer for this glitch, nor why it started in the first place. My computer is running perfectly, from streaming videos to working in speadsheets. Beats me!


Edited by ranchhand_, 20 February 2017 - 02:24 PM.

Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


#4 eth4n

eth4n

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:16 PM

Posted 20 February 2017 - 02:02 PM

Ah, ok. You're welcome, sorry I couldn't help more. From my experience, using GIMP on Windows is not a good experience.


Regards,

Ethan

 

If I don't reply within 48 hours, feel free to PM me.


#5 eth4n

eth4n

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:16 PM

Posted 20 February 2017 - 02:07 PM

Sorry, didn't notice the editation. Well, that's odd. Really no leftovers in %appdata%, %programdata% and so on?

 

If so, you got me there, out of my expertises.


Edited by eth4n, 20 February 2017 - 02:11 PM.

Regards,

Ethan

 

If I don't reply within 48 hours, feel free to PM me.


#6 ranchhand_

ranchhand_
  • Topic Starter

  • Members
  • 1,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:06:16 AM

Posted 20 February 2017 - 04:27 PM

 

leftovers in %appdata%, %programdata%

Can you give me the full path to those? I don't see them in my Gimp installation folder in Explore.


Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


#7 eth4n

eth4n

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:16 PM

Posted 20 February 2017 - 04:40 PM

Sure, it should be:

C:\Users\username\AppData\Roaming\GIMP

You can easily get into the folder by pressing a keyboard shortcut Windows + R, pasting the path into the window and clicking OK.

 

Maybe also check the %localappdata% and %programdata% folder. These are valid paths and you can paste them into the Run box using the steps mentioned above.

 

After you uninstall GIMP and delete everything related to GIMP in these folders, try to install GIMP again.


Edited by eth4n, 20 February 2017 - 04:41 PM.

Regards,

Ethan

 

If I don't reply within 48 hours, feel free to PM me.


#8 ranchhand_

ranchhand_
  • Topic Starter

  • Members
  • 1,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:06:16 AM

Posted 20 February 2017 - 05:54 PM

Oh, I see...I thought that you meant some kind of data file directly in the Gimp installation folder; unfortunately, the AppData/Roaming folder has no GIMP folder at all...nothing there, maybe because I did not save anything from my new installs yet. Either way, since it isn't there there is nothing to delete (obviously).

Thanks again for the suggestion.


Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


#9 ranchhand_

ranchhand_
  • Topic Starter

  • Members
  • 1,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest
  • Local time:06:16 AM

Posted 20 February 2017 - 06:26 PM

Ok....crazy time, again....now Gimp is working fine, just like the good ol' days. I didn't do anything. Nada. Checked out the AppData folder, and deleted one empty Google folder. Rebooted Gimp and now it's working, at least until next time.

I'm going to hurry and get this project done before it glitches again!  :rolleyes:

Thanks again, I appreciate your interest and help.


Help Requests: If there is no reply after 3 days I remove the thread from my answer list. For further help PM me.


#10 eth4n

eth4n

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:16 PM

Posted 20 February 2017 - 06:33 PM

Wow, ok. Well, it works, that's important.  :lol:

 

I'm not sure I was very useful, but I was very happy to try! :)


Regards,

Ethan

 

If I don't reply within 48 hours, feel free to PM me.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users