Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Is my Epson Stylus NX415 simply too old?


  • Please log in to reply
5 replies to this topic

#1 OmegaWolf747

OmegaWolf747

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Michigan
  • Local time:03:48 PM

Posted 17 February 2017 - 09:38 PM

Epson Stylus NX415

Support page

 

As can be seen on the device's webpages, there's not a driver or software download link to be found. I realize the printer is almost seven years old and was officically discontinued, but I can't believe Epson would purposely remove all driver/software downloads for it.

 

Is there anywhere reputable that I can obtain the software for Windows 10?

 

Thank you.

Attached Files


What is this Internet you speak of?


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:48 PM

Posted 17 February 2017 - 09:49 PM

You can get the drivers here. Use the dropdown box to select your OS.

 

https://epson.com/Support/Printers/All-In-Ones/Epson-Stylus-Series/Epson-Stylus-NX415/s/SPT_C11CA44231?review-filter=Windows+10+64-bit



#3 OmegaWolf747

OmegaWolf747
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Michigan
  • Local time:03:48 PM

Posted 17 February 2017 - 09:54 PM

Thank you for the link. However, it just redirects me to the support page in my second thumbnail, with no links, dropdown box or anything else.

 

Could you post a screencap of what you're seeing? Because for some reason, I seem to be getting something else entirely. :-(

 

I just tried it in a different browser. Apparently, Pale Moon has "issues" with this site.

 

Thank you.


Edited by OmegaWolf747, 17 February 2017 - 09:55 PM.

What is this Internet you speak of?


#4 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:48 PM

Posted 17 February 2017 - 10:00 PM

Sure. This is what I see. Edit: I am added additional images.

 

 

 

 

Attached Files


Edited by JohnC_21, 17 February 2017 - 10:05 PM.


#5 OmegaWolf747

OmegaWolf747
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Michigan
  • Local time:03:48 PM

Posted 17 February 2017 - 10:01 PM

I switched over to Edge and finally saw the downloads. I can't understand why Pale Moon won't render that part of the page! I feel like a Grade A idiot now. Thank you for your help.


What is this Internet you speak of?


#6 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:48 PM

Posted 17 February 2017 - 10:06 PM

No problem, glad Edge worked for you. I was using Chrome. Thanks for the update.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users