Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port 5900 for remote desktop connection


  • Please log in to reply
1 reply to this topic

#1 TinoNgombo

TinoNgombo

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Luanda, Angola
  • Local time:06:03 AM

Posted 17 February 2017 - 05:24 AM

Hi all.

 

I'm trying to make a remote desktop connection to CentOS 7 clients via Windows 10. I got TightVNC installed.

 

Whenever I try to connect to, I get an error saying that there is no answer from the host.

 

Note: I also tried to disable the firewall and connect, but no success.

 

Should I add port 5900 to the firewall on the CentOS machines? If so, how do I do it?

 

Regards.



BC AdBot (Login to Remove)

 


#2 toofarnorth

toofarnorth

  • Members
  • 390 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:03 AM

Posted 05 March 2017 - 10:19 AM

Hello Tino

To add a firewall exception for VNC connections in Centos 7 you use this command:
firewall-cmd --permanent --add-port=5900/tcp

Then you need to reload the firewall:
firewall-cmd --reload

 

Hth!

tfn

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users