Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't delete, rename or format


  • Please log in to reply
1 reply to this topic

#1 NVIDIA

NVIDIA

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:30 AM

Posted 06 February 2017 - 09:01 AM

Hey everyone! 

I can't delete, rename or format the files/folders on my SD card. I don't know what the issue is and I've searched a lot on this issue but couldn't find much to resolve the issue. I've seen a lot of people suffering from this and nothing bold came forward. Not all the folders are like that, but some.

Here is a screenshot of the dirty folders:
3d9HOyy.jpg
 

I consider myself quite lucky as this has happened twice. Earlier, I was successful in removing and formatting my USB drive using chkdsk. Using chkdsk, windows dumped the unknown files to something more meaningful to it. 

But with my SD card chkdsk doesn't work properly. Probably because it is in fat, not sure though.

 

I have tried multiple unlockers/force shredders/deleting utilities but none worked.

 

Also, the files are bloated. The size of my card is 16gigabytes and the folder in the screenshot contains 44gigs alone.

 

Any help would be highly appreciated!!


Edited by NVIDIA, 06 February 2017 - 09:02 AM.


BC AdBot (Login to Remove)

 


#2 Platypus

Platypus

  • Global Moderator
  • 15,810 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:09:00 AM

Posted 06 February 2017 - 10:22 AM

The card is corrupted. Worst case scenario is if it is electrically faulty. If the card just has data corruption due to something like an unexpected removal, and Windows is balking only because of that, sometimes formatting the card in a different hardware device such as a camera will work. But is the write protect switch working correctly, and in the write enable position? Even if it is in position, sometimes the beginning of switch failure means it isn't enabling writing to the card, so no operations can be performed.


Top 5 things that never get done:

1.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users