Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Store/Windows Firewall service issue


  • Please log in to reply
1 reply to this topic

#1 skidajmo

skidajmo

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:01 PM

Posted 27 January 2017 - 07:32 PM

Hello! All of a sudden my Windows Store has just stopped working. I don't remember doing anything that could cause problems I'll describe, except performing latest Windows 10 regular update via update center. I've figured that out when I tried to launch the calculator. Some error popped out saying that it should be reinstalled or something like that. I haven't checked other Store apps at that moment, but when I tried to start my Windows Store its window just blinked for like half of a second and disappeared. I have tried everything and it didn't work.

I have tried this fix: http://www.thewindowsclub.com/re-register-windows-store-apps but after running it for every single package/app it reported an error:

PS C:\WINDOWS\system32> Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocati
on)\AppXManifest.xml"}
Add-AppxPackage : Deployment failed with HRESULT: 0x80073D0A, The package could not be installed because the Windows Fi
rewall service is not running. Enable the Windows Firewall service and try again.
error 0x80073D0A: Failed to install package Microsoft.AAD.BrokerPlugin_1000.14393.0.0_neutral_neutral_cw5n1h2txyewy bec
ause the firewall service is not running. Ensure that the firewall service is enabled and started.
NOTE: For additional information, look for [ActivityId] c62c0aa3-78fa-0000-3f3c-2cc6fa78d201 in the Event Log or use th
e command line Get-AppxLog -ActivityID c62c0aa3-78fa-0000-3f3c-2cc6fa78d201
At line:1 char:28
+ ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

It obviously pointed out that my firewall isn't running and that it failed because of it. It was disabled since I had 3rd party firewall which was part of an IS app. When I went to services Windows firewall service MpsSvc was set on auto, but it was disabled. When I tried to start it it popped out window with error 5, which reported that the service cannot be started.
I have tried everything, including: scanning with Farbar's tool which came back to me with these results:

Windows Firewall:
=============
MpsSvc Service is not running. Checking service configuration:
The start type of MpsSvc service is OK.
The ImagePath of MpsSvc service is OK.
The ServiceDll of MpsSvc service is OK.

File Check:
========
C:\Windows\System32\mpssvc.dll => File is digitally signed
C:\Windows\System32\bfe.dll => File is digitally signed
C:\Windows\System32\drivers\mpsdrv.sys => File is digitally signed
C:\Windows\System32\svchost.exe => File is digitally signed
C:\Windows\System32\rpcss.dll => File is digitally signed

I have also tried with deleting my IS application, which didn't help. Checked everything with JRT and some other tools, no sign of viruses and malware; tried registry hacks (adding MpsSvc as an user with full control); tried importing MpsSvc registry setting from another PC with Windows 10 Pro. I also have performed sfc /scannow but it didn't help. In report it said that there're some errors, after I checked them it was related to some dual permissions or something like that... So, neither of that worked.

Now I'm stuck, when I click on a magnifier button in a lower left corner of my W10 screen, nothing happens, and same for other Windows Store apps I was hoping that if I solve this firewall service problem could eventually reinstall Windows Store and apps (Cortana, Calc, etc.) with abovementioned fix (http://www.thewindowsclub.com/re-register-windows-store-apps).


Edited by skidajmo, 27 January 2017 - 07:49 PM.


BC AdBot (Login to Remove)

 


#2 skidajmo

skidajmo
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:01 PM

Posted 28 January 2017 - 12:56 AM

I have also tried Windows In-Place Upgrade and everything, but this detail from the screenshot at the end of this article helped me: https://answers.microsoft.com/en-us/windows/forum/windows_7-security/cannot-start-the-window-firewall-error-code-13/9fbffc18-93f3-40fa-814c-2b010bf41013


Edited by skidajmo, 28 January 2017 - 01:11 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users