Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

​Screen Brightness problems in Linux


  • Please log in to reply
2 replies to this topic

#1 synaptic

synaptic

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:12:49 AM

Posted 26 January 2017 - 09:21 AM

I know many folk have problems with the stock Linux drivers not working with certain makes/models of hardware .
Network connectivity seems to be the most common complaint .

For me , it was the Screen Brightness controls not functioning.
My main Linux Mint rig ( Samsung i5 64-bit laptop ) has an excessively bright screen and nothing I tried
could make the brightness control work .

I have spent months , on and off , trawling websites for a solution and I tried just about everything I could find ,
and I saw that many other people had similar issues with a variety of machines .

Examples include trying alternate drivers , adding the Brightness app , editing the xorg config file , installing Backlight ,

Voria or Cuttlefish
None of them worked , and some of them made me wish I had never started :)

Finally I found a workaround using xrandr , but to me it's not really a solution .

​As an old-school coder I don't think it's very pretty ( in fact it is plain ugly ) but it does work .

This site gave me the detail I needed :-
https://pkg-xorg.alioth.debian.org/howto/use-xrandr.html

First , to identify the monitor in use , type "xrandr"  into a terminal  ( omit the quotes )
In my case it is LVDS-1  ( internal panel )

Then using these commands
xrandr --output LVDS-1 --brightness 0.7
xrandr --output LVDS-1 --brightness 1.0

I created two new Launchers to execute them , and added a couple of icons .
One dims the screen to the level I want ( ~ 70 % ) and the other restores full brightness .

I wonder if anyone has experienced similar problems , and hopefully has come up with a slicker solution ?

Anyway , I thought I would share , just in case other people have been grinding away at this for as long as I have  :)

@mods I wasn't sure if this should be in the Tutorials section , please move it if needed


Edited by synaptic, 26 January 2017 - 09:47 AM.


BC AdBot (Login to Remove)

 


#2 dishdude1

dishdude1

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 26 January 2017 - 11:56 PM

Had the same problem, 6.2 on this page fixed it.

 

https://sites.google.com/site/easylinuxtipsproject/display#TOC-Brightness-of-the-display-is-wrong-and-not-adjustable



#3 synaptic

synaptic
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:12:49 AM

Posted 27 January 2017 - 03:23 AM

@dishdude1

 

Thanks for posting the link .

It looks like that fix is specific for Intel graphics though .

 

Unfortunately , I have the invidious  nvidia card -  :) 

....   I should have stated that with the specs in my post , sorry .

Update :-

Since posting I have done some testing with a handful of distros , and with a good mix of Arch , Debian and Ubuntu derivatives .

I also tested the same bunch on a second machine ( Vaio i5 with Intel graphics )

The Samsung with nvidia graphics never had any brightness control , regardless of distro , but the Vaio /Intel combo was flawless .

 

Just for reference , I tested every distro in both machines with the xrandr bodge , and it works everywhere .... 

....  but I still don't like it ...  :)


Edited by synaptic, 27 January 2017 - 07:32 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users