Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Drive acting strange


  • Please log in to reply
5 replies to this topic

#1 Whocraft

Whocraft

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:26 PM

Posted 19 January 2017 - 01:09 PM

Hello. My USB drives have been acting a little weird. I went to a friends house yesterday and had copied some files I wanted to show him. Strangely, it didn't have the file I had copied, but files that I had deleted off of it on my computer about a month ago. It is the same with my other USB drives. Everything I copy from my main PC either doesn't register OR is not playable. The error is 'Class not registered' for video files. My anti-virus (Kaspersky Internet Security) has not detected any objects. Please help!


Edited by Whocraft, 19 January 2017 - 01:12 PM.


BC AdBot (Login to Remove)

 


#2 RolandJS

RolandJS

  • Members
  • 4,512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:10:26 PM

Posted 19 January 2017 - 01:21 PM

I'm wondering if explorer.exe and usb circuitry is not co-operating very well; or [this is a wild card] does the computer use some sort of automatic backup to an online place?  Let's pick just one usb flash drive -- does it do the same weird thing in all of the computer's usb ports or just one?  This usb flash drive is aok acting in somebody else's computer, correct?


"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#3 RolandJS

RolandJS

  • Members
  • 4,512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:10:26 PM

Posted 19 January 2017 - 01:27 PM

...error is 'Class not registered' for video files...

Google is my friend -- I found two possible solutions that may or may not apply to your situation:

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-error-message-class-not-registered-in/f4b5753c-c28e-4696-bde7-6e811bd285fd

TerenceMarlow replied on August 26, 2015rsp-expand-down.png?ver=17.1.18.4

I solved this problem eventually.......   Start button>All apps>Windows system>Default Programs.  You will see two "Default programs" ; use either, though the second (bearing the settings icon).  The first button allows you to set a range of defaults within Windows 10.  Best of luck!

 

https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/how-to-fix-error-message-class-not-registered-in/1a2e8a40-6dec-42e1-bb85-70a719e9fbbb

When right-clicking on variety of files from variety of software programs,

then clicking on Properties.

 

Both of the above have more answer posts.  Hope you find a solution!

 

 


Edited by RolandJS, 19 January 2017 - 01:27 PM.

"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#4 Whocraft

Whocraft
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:26 PM

Posted 19 January 2017 - 01:27 PM

Ok, no. All of my USB drives have items that have been copied from my MAIN PC. These items do not show up on ANY of my other computers except my main one. This happened only recently. I believe it has something to do with the drives themselves, possibly a virus that isn't detectable. I did just recently download a large amount of files from the Steam website, but that shouldn't have been a problem. Yes, it WAS the legit website. And all of the ports act the same, nothing comes up



#5 RolandJS

RolandJS

  • Members
  • 4,512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:10:26 PM

Posted 19 January 2017 - 01:29 PM

Whocraft, I'm sorry for my rabbit-hole -- hopefully, the malware team will be in shortly to guide you to good resolution!   And, quick question:  what format are these usb flash drives?


Edited by RolandJS, 19 January 2017 - 01:31 PM.

"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.

http://collegecafe.fr.yuku.com/forums/45/Computer-Technologies/

Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)


#6 hamluis

hamluis

    Moderator


  • Moderator
  • 55,552 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:26 PM

Posted 19 January 2017 - 02:10 PM

Worth a look:  https://www.bleepingcomputer.com/forums/t/591645/i-keep-getting-the-class-not-registered-error/ .

 

If it's a Win 10 problem...you would probably be better served by posting it there, rather than here in External Hardware.

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users