Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

After Power Outage USB Headset Shows In Device Manager As "Generic USB Hub"


  • Please log in to reply
2 replies to this topic

#1 EmptyAlice

EmptyAlice

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:01:38 AM

Posted 08 January 2017 - 06:13 PM

Hi,

 

With a huge storm hitting California, I experienced a power outage in my area. I currently have a Steelseries Siberia 800 wireless headset which is not working. The front of the transmitter is completely black, instead of lighting up and showing the battery life and all of the available sound options. The transmitter has a DC power cord plugged into my power strip, and it has a USB cord plugged straight into the back of my desktop. Before the storm hit I was successfully using my headset, but my computer was on when the power outage occurred. Now, when I boot up my computer, the transmitter doesn't turn on. I've tried to plug the power block into different outlets and slots on my power strip. The power strip is working fine. I've tried to plug the USB cable into USB 3.1 and USB 2.0 slots in the back of my computer, and I also tried plugging it into the USB 2.0 slots on the front of my computer. 

 

I'm using Windows 7 64bit, by the way. Whenever I plug the transmitter's USB cord back in, under Device Manager it is now only showing up as "Generic USB Hub," rather than detecting the device as a headset. I've tried to right click on the "Generic USB Hub" and have tried "Update Driver Software" and "automatically check online for drivers" and it tells me the drivers are up-to-date. I've also done Right Click -> Properties -> Disable -> Unplug Device -> Plug Device Back In as well as Right Click -> Properties -> Uninstall -> Unplug Device -> Plug Device Back In. I've also tried using Driver Identifier to locate manufacturer updates for my USB hubs. I've tested the USB slots with a Logitech webcam and in the slots it is indeed properly recognizing my webcam, but not the headset.

 

I've checked the Steelseries website and I can't manually find the device drivers for the Siberia 800 on their website. They currently are using "Steelseries Engine 3" for device drivers, so I installed it, and when I plug the USB back in their engine does not indicate that any device has been plugged in.

 

What do?



BC AdBot (Login to Remove)

 


#2 mjd420nova

mjd420nova

  • Members
  • 1,885 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:38 AM

Posted 08 January 2017 - 07:01 PM

Power outages can really take a toll when units are running.  USB ports are prone to getting induced currents from other devices during voltage excursions.  Sounds like the headset didn't like the voltage drop and has failed.



#3 JohnC_21

JohnC_21

  • Members
  • 24,657 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:38 AM

Posted 08 January 2017 - 07:05 PM

See this video at about 50 seconds in. When plugging in the power to the transmitter you should at least see the logo. If it's black then I would think the transmitter box has failed. I would submit a ticket to steelseries.

 

https://support.steelseries.com/hc/en-us/articles/224942187-How-do-I-setup-my-Siberia-840-






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users