Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HD & Partition fun!


  • Please log in to reply
4 replies to this topic

#1 BmSKT

BmSKT

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 31 December 2016 - 11:01 PM

So here has been my process so far:

- Asus Notebook w/ Windows 10, was reformatted to Debian Linux
- Attempting to go back to Windows 10 (not that I don't like Linux, just wanted it for something else)

         - Had to change several BIOS settings for it to recognize the bootable Windows USB

         - Windows installer griped that it didn't want to install on an MBR, and wanted GPT instead.
         - Option to reformat was grayed out, so after several attempts I deleted that partition, which is now reading unallocated.

         - Trying to create a new partition exists as an option. Clicking it pops a box to select memory size, but once selected does nothing.

- Attempted DBAN tool, BIOS doesn't recognize it to boot from it. Same thing with Partition Wizard 9.1.
- Just to see if it would work, attempted to install Unbuntu, which won't finish install by saying the drive has 0 bytes left on it.


Any ideas? I'm stumped here on where else to go or how else to proceed. Been at it all day with no luck so far; any guidance or input would be really helpful! Thanks guys.


Edited by BmSKT, 31 December 2016 - 11:03 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:50 AM

Posted 31 December 2016 - 11:08 PM

Make sure UEFI mode and SecureBoot are enabled.

Boot the Windows 10 DVD or USB

At the screen where it asks for language press Shift + F10

This will open a command prompt

 

Type the following commands

 

diskpart

list disk 

select disk X  where X is the number associated with the HDD you are installing Windows to. If you have one disk it will be 0

clean             This will delete all existing partitions and your data too

convert GPT    Will initialize the disk as GPT

exit   exits out of diskpart

exit   exits out of command prompt

 

Continue with the install

 

Edit: Tap F8 at boot on an Asus. This will get you a boot menu where you can select the USB. 


Edited by JohnC_21, 01 January 2017 - 09:23 AM.


#3 BmSKT

BmSKT
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 31 December 2016 - 11:22 PM

Make sure UEFI mode and SecureBoot are enabled.

Boot the Windows 10 DVD or USB

At the screen where it asks for language press Shift + F10

This will open a command prompt

 

Type the following commands

 

diskpart

list disk 

select disk X  where X is the number associated with the HDD you are installing Windows to. If you have one disk it will be 0

clean             This will delete all existing partitions and your data too

convert GPT    Will initialize the disk as GPT

exit   exits out of diskpart

exit   exits out of command prompt

 

Continue with the install

I'll give that a shot tonight! The reason I had to change some BIOS settings is because it wasn't recognizing the USB, so I'm curious to see if it will still like it.

Will report back with an update when I have one. Thank you again for the guidance.



#4 BmSKT

BmSKT
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 02 January 2017 - 12:15 AM

So after messing around with getting the Asus board to recognize the boot media (had to enable CSM), I was finally able to boot into the Windows USB.
Had the same issues with it not liking how the partition was formatted. Popped the CLI and used the clean command, and that was all I needed to do! I dropped back over to the install GUI, it gave me the option to proceed on Disk 0, and it's currently installing! Whoop!

If it ganks during install I'll start another thread, but thanks for the CLI magic and I learned what to look for/search for in the future!



#5 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:50 AM

Posted 02 January 2017 - 08:37 AM

You need to make sure CSM boot is not enabled. UEFI mode needs to be enabled for Windows 10 on a UEFI computer with SecureBoot enabled.

 

I would download an iso of your version of Windows using the media creation tool or have the tool make a bootable USB flash drive.

 

If you download the iso then use Rufus to create the bootable flash drive. 

 

Rufus Instructions:

Run Rufus with the USB flash drive attached. Select GPT partition scheme UEFI. Leave all boxes as checked. Select iso image in the dropdown box if FreeDos is shown, click the icon, and browse to the Windows 10 iso file. Press Start. Any data on the flash drive will need to be backed up as the drive will be formatted.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users