Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disk Quota


  • Please log in to reply
4 replies to this topic

#1 toms@mcs

toms@mcs

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 28 August 2006 - 09:30 PM

Hi there,

I want to enable disk quotas on our server 2003 drive, but all the options are grayed out on the quotas tab.
I understand that there are quota options in the GPO but when I set them this had the effect of limiting disk space on the client PC and caused all sorts of problems. I only want to apply quotas to the server drive.

What have I failed to do?

BC AdBot (Login to Remove)

 


#2 buddy215

buddy215

  • Moderator
  • 13,196 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:08:02 AM

Posted 28 August 2006 - 09:43 PM

First, you'll need to log onto your computer as the Administrator, or as someone with Administrator privileges. Next, use your mouse to right-click a drive's icon in the My Computer folder. From the context menu that appears, select "Properties", then click the "Quota" tab of the "Drive Properties" dialog.

Now you're ready to enable Windows' quota feature. Just place a checkmark in the box labeled "Enable quota management". On this dialog you can also select the amount of space users are allotted, and when they should be warned they are nearing their limit.

Initially, the limit you specify here will apply to all users of this drive. But you can customize quotas, giving different each user his or her own disk space limit.

Just click on this window's "Quota Entries" button. You'll then see a list of all users authorized to access this computer, alongside their individual quota settings. Double-click a user's name, and you can adjust the limit and warning level of the selected user. You can even remove quota restrictions from especially responsible and privileged users, such as yourself. :thumbsup:

What does this have to do with the new Drive Info program? Now, the program reveals whether quotas are supported on each drive. If so, it goes further, telling us if quotas are currently enabled, and reporting the current disk space limit and warning level for the current user. It even shows how close we are to filling our portion of the drive, by displaying the percentage of our quota that is already in use!

Found on the web at:http://www.karenware.com/newsletters/2003/2003-09-17.asp
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#3 toms@mcs

toms@mcs
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 28 August 2006 - 10:11 PM

Thanks for the quick reply,

I am Admin and Domain Admin, I understand that if you do not have admin rights that the Quota tab does not even appear. The tab does appear but the enable quota check box is grayed out. How do I get it un-grayed?

#4 toms@mcs

toms@mcs
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 29 August 2006 - 11:05 PM

Is there a 2003 GPO expert in the forum?

If I enable Disk Quota in Default Domain Policy then the items on the quota tab on the client PC's are enabled, but the items on the quota tab on the server are sill grayed out. I only wish to enable the disk quota on the server.

What say you.

#5 toms@mcs

toms@mcs
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 03 September 2006 - 11:46 PM

Fixed it, a bit of a hack as I still think the GPO should work for the server.
Forced Disk Quota to be enabled via the vbs below.

http://www.microsoft.com/technet/scriptcen...003/quotas.mspx

Script below in file EnableDiskQuotas.vbs

' only dis/enables D:
' to disable Const ENFORCE_QUOTAS = 0

Const ENFORCE_QUOTAS = 2

strComputer = "."
Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
Set colDisks = objWMIService.ExecQuery _
("Select * from Win32_QuotaSetting Where VolumePath = 'D:\\'")

For Each objDisk in colDisks
objDisk.State = ENFORCE_QUOTAS
objDisk.Put_
Next




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users