Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Audio / mouse hitching (when connected to the internet?)


  • Please log in to reply
3 replies to this topic

#1 JangleJ

JangleJ

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:28 AM

Posted 26 December 2016 - 07:14 PM

My computer occasionally glitches anywhere from multiple times a second to once every ten seconds. By 'glitch' I mean any audio playing goes kzzt for a fraction of a second, and the mouse cursor skips, everything just skips. This happens for music stored on my hard drive and streaming video/audio.

 

This only started when I reset one of the routers at my house a few days ago. There are two routers, one plugged into the other, both have wifi, but the second (the router that is plugged into the other, not directly to our ISP or whatever) was more reliable and the one I used. Before I remembered this, I tried a few fixes:

 

 

I tried using the Windows Repair tool from Tweaking - didn't work, so I restored my old registers.

 

I reinstalled my audio, wireless card and video drivers to the newest versions - didn't work.

 

I became religious and tried prayer - didn't work.

 

 

finally I remembered when this actually started and I unplugged one of the damn routers (the good one). The problem went away, no more hitching, but only for ~5 minutes and then it returned.

 

At this point I tried setting my PC to airplane mode, and suddenly there were no more hitches at all. Both for audio on my PC and for videos that I gave time to buffer with an active connection, and then set airplane mode. Turning wifi back on and watching those same buffered sections does produce the hitches.

 

Right now my wifi is on and there are occasional hitches, but not as many as before I began to type this out.

 

(This does not happen to my laptop, which uses the same wifi)

 

I don't understand what's going on.

 

 

(I remember reading something about having multiple audio drivers could do this? And I do have two 'sound' tabs on my DirectX diag tool thing.)

 

 

 

 

 

Attached Files



BC AdBot (Login to Remove)

 


#2 Zone_86

Zone_86

  • Members
  • 303 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:28 AM

Posted 26 December 2016 - 07:39 PM

You didn't screenshot your actual sound tabs just the system/display tabs. Perhaps you have HDMI active along with your regular sound (onboard or other) also active at the same time with your GTX 970? Normally, if your Display is also sound capable (or TV) and you are hooked up via HDMI you will be using that driver by default instead of your onboard sound driver. I see you are using an MSI Z87-G45 motherboard though and I am also using the same board with a 4770k I have no issues though I only use one router with my network.

 

What I would do is try to isolate the issue and disconnect from both routers and play stuff completely offline, To me it sounds like you have a network ripple effect that is being kicked off by a surge from your network causing audio interference -- possibly-- but first try looking some offline songs for 1-2 hours and tell me if you notice any skipping or anything at all that you noticed before. From that point if you say "no" and I think that is what you will say I would get into trying other electrical outlets for your network connection etc, and also try another power bar (surge protect). You can also try uninstalling your nVidia drivers and when you reinstall omit the HDMI/sound drivers, or alternatively you can right click it in the device manager and "disable". If your primary sound (that you actually use) HDMI or analog onboard realtek?

 

Also think about the last time you know of that your setup (as is) worked correctly and the specific changes you may have made past that point.



#3 JangleJ

JangleJ
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:28 AM

Posted 26 December 2016 - 08:42 PM

Thanks for the reply! And sorry - attached shots of the sound tabs.

 

I was using a Displayport cable to hook my PC to my monitor. Apparently it does audio too, so I switched it to a DVI just now. (As far as I'm aware my monitor does not have speakers, but figured 'why not')

 

For audio I use the built in jacks on the MB, and I'm using Realtek drivers.

 

My selected playback device is "Speakers (Realtek High Def Audio)" the other option is "Realtek digital output (realtek high def audio)"

 

 

 

(As I'm typing this the hitches are not happening anymore, in that I can't get it to happen again with the usual methods - streaming or playing audio.)

 

 

 

Here's the timeline of events:

 

-the distant past, everything is fine, our two routers exist in peace.

 

-It's about three days ago: my connection is being patchy. I notice that I'm connected to the bad router and not the good one. I can't find its ID in the list of available connections anymore. I reset it to defaults and set it up. Initially it set up as a 'fully functional router,' not an extension of the existing one.

 

-Glitches start happening.

 

-I reset the router again and set it to be an extension of the existing router.

 

-Glitches continue.

 

-I forget that the glitches started when I messed with the router

 

-I troubleshoot and do the things I listed in my first post

 

-today, finally shut off the trouble router

 

-problems persist for a while anyways

 

-make that first post

 

-get reply

 

-swap out my displayport for a DVI

 

-start writing this

 

-hitching stops

 

-we arrive at the present

 

 

As far as I remember I didn't make any changes before the problem arose other than fiddling with that router.

 

 

The trouble router is still off, I'm still connected to wifi, glitches still not happening. I feel pretty dumb and confused.

 

 

Anyways I guess I accept this reality. I'm gonna give it a hot minute and see if the problem comes back, if it does I'll go offline and give that a run and go from there. (Still good at time of post)

 

 

 

 

 

 

Attached Files



#4 JangleJ

JangleJ
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:28 AM

Posted 02 January 2017 - 03:44 PM

It's been about six days, the glitches were so infrequent as to be not much of a bother.

 

After a power outage yesterday they returned in full force, I went the nuclear option and did a clean install of Windows10. The problem was still around earlier, it's gone for the moment, I'm going to say it's my wireless card and try a new one.

 

Can anyone tell me how this even works? How just being connected to wifi can cause your computer to 'skip'? I genuinely don't get how that works.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users