Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External HDD "Corrupted""Access Denied" cannot seem to repair. Please help!


  • Please log in to reply
3 replies to this topic

#1 polymorfix

polymorfix

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:07 PM

Posted 26 December 2016 - 03:12 AM

Hello all,

 

I have a Seagate External HDD 1TB Model: SRD0FN1 It is only a few months old and have never had an issue in the past. Shut down my desktop running Windows 10, and plugged in to my laptop also running Windows 10, turned on my laptop and I get a message saying that the disk needs repaired. Having had this problem with a thumb drive, I decided to shut down, and wait to plug it back in to my desktop because the data on the disk is very valuable to me.

 

Low and behold, I have a problem on the desktop also. Although the drive shows up everywhere (disk management, "This PC", my device list on the taskbar) I am getting a message that says "Access is denied" when the drive attempts to autoplay. I have tried these methods to correct:

 

Try a different USB port - No improvements

Change the drive letter - No improvements

Scan and repair - when this is done through disk management, it appears to work but there is no improvement.

chkdsk /r - I tried this first and the message i received said "The file system is NTFS. the disk cannot be locked"

chkdsk /r /f /x - by pressing "Win+X" and running admin elevated Command Prompt, I was able to perform this operation, but once completed it states there are no bad sectors                               and shows no improvement. 

 

Also, while in command prompt, I can navigate to the drive, and see all the files in the drive. It seems to be only windows that will not access it. Seagate's disk check utility freezes and stops responding when I try to use it. I have managed to get the volume info to show the population of the drive. The drive is not partitioned. Disk Management shows the drive to be healthy and the used space on the drive is recognized. I am... at a loss for words and ideas.

 

I expect to lose SOME info, but as a whole it is invaluable. I'm not very familiar with this and have only been going by forum threads based on other users issues. Perhaps if I were able to schedule the task during boot it would be more effective, but I cant seem to figure out how that is done.

 

Thank you for your time and consideration, any help is greatly appreciated!


Edited by polymorfix, 26 December 2016 - 03:40 AM.


BC AdBot (Login to Remove)

 


#2 opera

opera

  • Members
  • 947 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:07 PM

Posted 26 December 2016 - 03:49 AM

Have you tried any of the things listed here?

 

http://www.tomshardware.co.uk/answers/id-2159003/external-hard-drive-access-denied.html



#3 JohnC_21

JohnC_21

  • Members
  • 22,589 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:07 PM

Posted 26 December 2016 - 09:24 AM

Seagate's disk check utility freezes and stops responding when I try to use it.

 

I don't think Seagate's disk check utility would freeze if this was only a permissions problem.

 

If opera's link does not solve the problem then you can use a live linux disk to recover the data if it can mount the partition. If you need instructions I can post them.



#4 polymorfix

polymorfix
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:07 PM

Posted 26 December 2016 - 01:50 PM

Operas solution seems to work! Thank you!!! At first it would not "enumerate access" for the recycle bin on my external drive, but I have never set this drive to anything but removable media, so Im not sure why there is a recycle bin to begin with... Perhaps my laptop did something when I booted up while the drive was plugged in. IT IS a fresh copy of Windows 10. Now I am going through each folder one by one and giving myself permission to access them. 

 

I suppose the freezing utility could be unrelated to the drive. My PC is not in the BEST of condition, I abuse it with heavy and arduous tasks on a regular basis...

 

Thanks again!

 

--addendum--

 

After all is said and done I did lose some files. Between my OP and receiving a response, I was able to start copying files from the drive using xcopy. Either the process of xcopy or whatever created the issue in the first place must be the culprit. Sad but overall I am pleased to have it back.


Edited by polymorfix, 26 December 2016 - 10:50 PM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users