Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Issue Ejecting Thumb Drives


  • Please log in to reply
1 reply to this topic

#1 MasterNe0

MasterNe0

  • Members
  • 107 posts
  • OFFLINE
  •  
  • Local time:03:46 AM

Posted 21 December 2016 - 03:03 PM

We recently purchase a bunch of 256GB thumb drives, formatted them to NTFS and using them for a client's desktop that doing a robocopy of files as a weekly backup option.We would swap the drives from M-F in a weekly cycle.

 

We been having a wierd problem where the drives don't seem to eject if we use the safety remove option from the taskbar as it would warn us the drive is still in use.

 

The only way to eject them would be to go to My Computer and eject them that way, clicking on "Continue" if needed to force a eject as it warns us drive in use.

 

What I can't figure out is what using the drive. I tried using process explorer but can't locate anything that I can identity using it.

 

We never had a problem in the past with smaller drives (those were left as either FAT or exFat format).

 

However these 256gb drives seems to not want to eject.

 

I already try turning off the indexer but not sure if that would fix them problem. We tried another different manufacturer drives to make sure those are fine. We dont have any errors with the robocopy on these drives.

 

What could cause the drives to be "in use" when nothing accessing them. rebooting the PC isn't really the best option to get them remove.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,638 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:46 AM

Posted 21 December 2016 - 03:36 PM

See this theard. Process Monitor may be able to detect the process causing the issue.

 

https://www.bleepingcomputer.com/forums/t/591692/safely-eject-media/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users