Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win 7 Script for Robocopy I use not working on windows 10


  • Please log in to reply
2 replies to this topic

#1 mapper3d

mapper3d

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 18 December 2016 - 03:25 PM

I have a script running robocopy to copy about 1.5 tb of data from one machine to another. Works fine on our windows 7 machines. But on Windows 10 it doesnt run.
Its something like this (im at home right now & dont have the script with me)  Note: im doing robocopy from win10 machine to another win10 machine on the LAN.

robocopy "\\NetworkMachineSource1\dir\another_dir\ C:\program files\dir\another_dir\ /mir /fx " 

Anyways, from my research today im thinking there is a problem with permissions with computer source and destination with the /mir command. 

I tried it with /MIR /SEC and /SECFIX, tried without the /MIR

Anyone encounter this yet? Im kinda a noob when it comes to the windows 10 changes on owner and permissions of folders and files. Would really appreciate a response if you can assist me or even point me to the right direction.



BC AdBot (Login to Remove)

 


#2 mapper3d

mapper3d
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 18 December 2016 - 03:38 PM

Actually the better question to ask: Is there any known issues or changes on windows 10 using robocopy. Im sure its something simple. 



#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:05:15 PM

Posted 07 January 2018 - 09:19 AM

Windows 10 comes with Robocopy installed.  To learn more about it open the Command Prompt, copy and paste the command below in the Command Prompt, then press Enter.

 

To open the Command Prompt click/tap on the Taskbar Search icon (magnifing glass) and type cdm.

You will see Command Prompt under Best match, right click on Command Prompt and select Run as administrator.

Copy and paste the command below in the Command Prompt, then press Enter.

Robocopy /?

 

Microsoft has a article you can find here which provides the command syntax and all of its options. 


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users