Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Device Not Recognized on Restart


  • Please log in to reply
8 replies to this topic

#1 d2produce

d2produce

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 16 December 2016 - 08:45 AM

So I have a windows 10 BRIX mini computer i7 Intel processor.
 
And I have a Mediasonic ProBox 4-Bay HDD enclosure.
 
I set the Mediasonic to USB and Awake with computer.
 
So when I restart my computer the Mediasonic is running just fine.  However it's not being recognized by my computer.  I've been manually unplugging and replugging the USB in the back of the Brix for my drives to pop up.  Is there a way I can have them be recognized automatically at startup or at least a way I can do a USB search so the computer finds them itself without having to manually reseat the USB?


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 16 December 2016 - 08:53 AM

Disable fast startup in power settings. If there is a Fastboot or Quickboot option in your UEFI settings disable it.



#3 d2produce

d2produce
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 18 December 2016 - 08:04 PM

I turned off "Fast Startup" in the Power Options in Control Panel but it did not help.  I restarted my computer and although my External drive bay is running, the pc did not recognize it until I unplugged and replugged the USB port.

 

What else can I try?


Edited by d2produce, 18 December 2016 - 08:04 PM.


#4 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 18 December 2016 - 08:16 PM

Is there a FastBoot or QuickBoot in your UEFI settings? Those should also be disabled.

 

The only other thing I can think of is to  open Device Manager in an admin account. Click the top most tree, your PC, and select Action > Scan for Hardware changes. Does the external get detected? 

 

If that does not detect the drive, unplug and attach. Go to Device Manager. Right click your external in Device Manager, select Properties, and under the Power Management tab make sure the box next to let the PC turn off the device to save power is unchecked.

 

Also disable USB selective suspend. This guide is for 7 but it's similar to 10.

 

If you connect the external to a different USB port does the same thing happen?



#5 d2produce

d2produce
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 19 December 2016 - 07:16 PM

I'm so happy.  It was that USB Suspend anti-idle setting and it was so easy to fix!  Thank you for your help buddy!


Edited by d2produce, 19 December 2016 - 07:16 PM.


#6 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 19 December 2016 - 07:29 PM

Your Welcome. Glad it was an easy fix. Thanks for the update.



#7 d2produce

d2produce
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 26 December 2016 - 09:41 PM

Unfortunately it happened again.  I checked the USB Suspend setting and it is still disabled.  Fastboot both in System settings and in the Bios is disabled.

 

How do I locate the device(s) in Device manager to change the power settings?  Again it's a Media Sonic 4 Drive bay and it has 3x SATA Hdds in it a 8tb a 4tb and a 1tb



#8 JohnC_21

JohnC_21

  • Members
  • 23,282 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:42 AM

Posted 26 December 2016 - 10:29 PM

I am not sure how to check which hub the device is using. Open Device Manager and open the USB controllers tree. Insert your USB external and you will see a new entry for Mass Storage Device. Right click, select Properties, and under Details select Location Information in the drop down box. This gives the HUB number but I don't know how to correlate that to the USB Root Hub in the list. You could Right Click every USB Root HUB and under the Power Management tab uncheck the box that allows the computer to turn off the device.



#9 d2produce

d2produce
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 11 January 2017 - 09:28 PM

I am not sure how to check which hub the device is using. Open Device Manager and open the USB controllers tree. Insert your USB external and you will see a new entry for Mass Storage Device. Right click, select Properties, and under Details select Location Information in the drop down box. This gives the HUB number but I don't know how to correlate that to the USB Root Hub in the list. You could Right Click every USB Root HUB and under the Power Management tab uncheck the box that allows the computer to turn off the device.

Going into Device Manager and selecting the correct "Mass Storage Device" and disabling the "turn off device" option like you said worked.  It has been starting up with all drives recognized consistently the past month.  Thank you.


Edited by d2produce, 11 January 2017 - 09:28 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users