Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Your connection is not private" / Wrong SSL certificate for Steamcommunity


  • Please log in to reply
5 replies to this topic

#1 _android_

_android_

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:19 PM

Posted 13 December 2016 - 12:37 PM

Hello,

 

I am trying to access sites from https://steamcommunity.com but I keep getting notified by the browser that the site is providing the wrong certificate, i.e.

"This server could not prove that it is steamcommunity.com; its security certificate is from m.ferguson.com"

 

I am using Windows 10 with Chrome.

 

I have tried to access the site through a different browser (Firefox), as well as a different computer on the same network (also Windows 10 with Chrome), and still encounter the same problem. The problem only seems to occur for https://steamcommunity.com, other https sites work fine.

 

Thanks in advance for your time and assistance,

Andrew



BC AdBot (Login to Remove)

 


#2 shadow_647

shadow_647

  • Banned
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:19 PM

Posted 13 December 2016 - 12:50 PM

IP for that place is 23.59.224.224 try joining by ip and see if it changes something for fun, just wondering if something up with your DNS.



#3 _android_

_android_
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:19 PM

Posted 13 December 2016 - 01:16 PM

Thanks for the reply.

 

http://23.59.224.224/ returns an error page:

 
Invalid URL
The requested URL "[no URL]", is invalid.
 
 
https://23.59.224.224/ returns the "your connection is not private" page:
 
This server could not prove that it is 23.59.224.224; its security certificate is from store.steampowered.com


#4 HolyCowz

HolyCowz

  • Members
  • 168 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:GMT
  • Local time:12:19 AM

Posted 13 December 2016 - 01:20 PM

Here's what I get when looking at it no green padlock first off.

 

From looking at other things on the page with my very limited knowledge it appears to be images requested from an insure source that seems to be causing it example from the page below
 
(index):1 Mixed Content: The page at 'hxxps://steamcommunity.com/' was loaded over HTTPS, but requested an insecure image 'hxxp://images.akamai.steamusercontent.com/ugc/101725789673581129/E04F46E65B…olation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside|640:*'. This request has been blocked; the content must be served over HTTPS.

 

 

 

When warning sign clicked:

Attackers might be able to see the images you look at on this site and trick you by modifying them.

And top right of my browser is says 

Page is trying to load a script from unauthenticated source.

 

I also scanned the link with virus total

https://www.virustotal.com/en/url/9c7db467df97af1e5c42103edd2e31fc4cc0f7efeea52772980608bf319d190f/analysis/1481652173/

 

The scanned with grc's https fingerprinting tool.
Domain Name: steamcommunity.com
Certificate Name: store.steampowered.com
EV: OK
Security Certificate's Authentic Fingerprint: EF:A9:87:C6:4D:6B:7B:60:F6:62:4A:37:D1:97:C3:F3:0C:4D:81:8D
 
when I had a look manually at the finger print it did match.
‎ef a9 87 c6 4d 6b 7b 60 f6 62 4a 37 d1 97 c3 f3 0c 4d 81 8d
 
 
Hope that's a little help probably nothing bad, but maybe someone with much better knowledge would be able to tell more clearly.
The login page seems to be ok green padlock appears and certificate is ok
 
I'd check your DNS like shadow advised and run a scan for malware using malware bytes and your own antivirus.
 
To check your dns open command prompt and type ipconfig/all scroll down and you should see 2 entries under the title DNS servers you can then google them if you don't know if they are correct or not.
 

Edited by HolyCowz, 13 December 2016 - 04:55 PM.


#5 _android_

_android_
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:19 PM

Posted 14 December 2016 - 02:36 PM

Thanks for the response.

 

Both Windows Defender and Malware Bytes came up clean.

 

When I check the DNS server info using "ipconfig /all", both listings are for 192.168.1.1 (which is my router I suppose). In the router admin page the WAN DNS setting "connect to DNS server automatically" is enabled.

 

 

Today, when I try to access https://steamcommunity.com I get a different error:

 
This site can’t be reached
 
The webpage at https://steamcommunity.com/ might be temporarily down or it may have moved permanently to a new web address.
ERR_SSL_UNRECOGNIZED_NAME_ALERT
 
 
 
I just tried manually setting the WAN DNS to Google's DNS (8.8.8.8 and 8.8.4.4) but that doesn't seem to make a difference as to whether I can access https://steamcommunity.com


#6 HolyCowz

HolyCowz

  • Members
  • 168 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:GMT
  • Local time:12:19 AM

Posted 14 December 2016 - 04:47 PM

Seems odd it works the same for me today as it did yesterday just tried. Something must be missconfigured just a matter of finding out what.

If I where you i'd get some one to take a deep look for malware in the malware section first just to be sure and rule that out as a cause. 

Then just a matter of resetting things 1 at a time till you find whats causing it.

In the mean time try this below

 

uninstall your browser and then use ccleaner to clean all temp files and then reinstall it.

Try to change your dns again

How to change DNS just swap open dns for the google one you want the instructions will work for both.

https://support.opendns.com/hc/en-us/articles/228007207-Windows-10-Configuration-Instructions

After you change dns try flushing the cache open cmd prompt and type ipconfig/flushdns

Then run ccleaner to clear temporary files. (don't use the registry option)

Then open cmd prompt as admin right click it and choose run as admin and type arp -d then hit enter close it down. 

Now see what DNS settings you get by typing ipconfig/all again it should say 8.8.8.8 and 8.8.4.4 not 192.168.1.1

 

Reopen your browser and try again






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users