Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft edge


  • Please log in to reply
No replies to this topic

#1 bug1971

bug1971

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pa, USA
  • Local time:09:49 PM

Posted 09 December 2016 - 01:02 PM

Hello fellow Pc enthusiast! Since the Anniversary  update of Windows 10 home I have noticed that Microsoft edge has become a lot slower. I had the last pass extension and the ad block extension . I thought those might be the problem so I uninstalled them but still it's slow and hangs a lot. Does anyone else have this problem and if so is there a fix for it? It's a shame because I really liked Edge but now I am using Chrome until I can fix this problem. I have tried just about everything that I could think of but with no luck. Other browsers like IE and Chrome are running normally. I am a Comcast customer and my download speed is 200MBs

  



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users