Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows recognizes but does not show various USB devices in My Computer


  • Please log in to reply
1 reply to this topic

#1 Sylveon Fetish

Sylveon Fetish

  • Members
  • 426 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:34 AM

Posted 04 December 2016 - 10:58 AM

I am having an issue when I plug in various USB devices such as flash drives, various Android phones and tablets, MP3 players, etc where Windows will make the "hardware inserted" sound effect but does not show any of these devices in My Computer. Right clicking and selecting "refresh" still does not show these devices in My Computer, they will not show these devices in My Computer whatsoever. Windows knows it is plugged in, it made the hardware inserted sound, and did not install any new drivers, so it knows that it is a device that I plugged into the computer before. It just won't show it in My Computer no matter what I do. There is a wide variety of devices that will not show up in My Computer. All of which will only show up maybe 30% of all attempts.

 

This is a Windows 7 Ultimate Dell Optiplex 780



BC AdBot (Login to Remove)

 


#2 shadow_647

shadow_647

  • Banned
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:34 AM

Posted 04 December 2016 - 11:42 AM

Odd, when the last time you reinstalled windows & do you have a addon card for USB ? only asking cus i had to replace mine "add on card" cus all the USB died on my mobo.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users