Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need help finding the correct AMD APU video driver for 7 64 bit


  • Please log in to reply
4 replies to this topic

#1 Tim_K

Tim_K

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 29 November 2016 - 10:42 PM

I am working on an HP laptop, model 15-f305dx.  It has the AMD A6-5200 APU cpu in it.

 

I did a full fresh disk wipe and reload with 7 Pro 64 bit.  The computer works fine except for the video drivers.  It has the latest version of Java 8-111 and Adobe Flash player in it too.

 

It is going to some old lady, and it is the end of the world if the damn Spider Solitaire that comes in the Windows Games doesn't work. 

 

When I tried to play the game without a specific video driver installed, and Device Manager showing "Standard VGA Graphics Adapter", trying to play Solitaire just says the hardware acceleration is disabled or no video driver.

 

Then, when I tried installing a few video drivers, such as the 15.2 version on the HP downloads page, or the latest  AMD 16.9.2 minimal Crimson driver, it just locks the computer up hardcore.  I have to go into Safe Mode and do a system restore to get it functioning again.

 

And idea where I can find a good video driver for this thing, and what version?



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,295 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:22 PM

Posted 29 November 2016 - 11:27 PM

Try this one

 

http://support.amd.com/en-us/download/apu?os=Windows+7+-+64

 

http://support.amd.com/en-us/kb-articles/Pages/desktop-apu-drivers.aspx#a6



#3 Tim_K

Tim_K
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 29 November 2016 - 11:29 PM

Yes, I did try that one, and the one in your second link for this 5200 APU.  Locks up the pc hardcore on the first restart, can't do anything. I know it seems like the right driver, and it SHOULD work but it doesn't.  And I have worked on hundreds of PCs, this rarely happens.

 

Maybe an older driver version?


Edited by Tim_K, 29 November 2016 - 11:32 PM.


#4 Tim_K

Tim_K
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 30 November 2016 - 01:39 AM

Finally found one that worked, the 15.7.1 legacy driver.

 

http://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows+7+-+64



#5 JohnC_21

JohnC_21

  • Members
  • 24,295 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:22 PM

Posted 30 November 2016 - 08:18 AM

Thanks for the update. I bookmarked the link. Interesting that APU was not mentioned in the link. This must be the last Catalyst driver before the Crimson update.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users