Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Trying to network 4 computers together where we can share files easily

  • Please log in to reply
6 replies to this topic

#1 MaverickTech


  • Members
  • 2 posts
  • Local time:05:21 PM

Posted 28 November 2016 - 07:05 PM

Help me....

​I'm out of ideas. No, I take that back, I have an idea; but I can't really completely delete the network and start over fresh easily...

​A previous employee set up the network and supposedly it worked fine for a while, but then they slowly started to not work.

​As it is right now, all four computers (running Windows 10) can see each other in the network. There is only one computer that everyone can share with, but it cannot share back. So I can put an excel file on the Desktop of that computer from my computer, but it can't do that to mine. I've looked at all the settings on that computer and have tried to replicate them on the others, but nothing changes.

​Can someone give me some advice on what I'm missing?

Thanks in advance. 

BC AdBot (Login to Remove)


#2 Wand3r3r


  • Members
  • 2,027 posts
  • Local time:04:21 PM

Posted 29 November 2016 - 12:53 AM

There are a number of good reasons to have a central file/app server.  Backup is one reason.  Easier to maintain is another.


User accounts need to exist on all pc and they need to be assigned to the shares.


I do suggest you don't do that though as it leads to copies of work with disconnected edits.  Better to work from one place on the network.

#3 MaverickTech

  • Topic Starter

  • Members
  • 2 posts
  • Local time:05:21 PM

Posted 30 November 2016 - 01:58 PM

I see what you mean and have brought this up to the boss, but he wants what he wants...

​So to be able to connect two PCs where we can edit each other's Desktop I'd need to put both user's accounts on both computers? With Windows 10 would I do it as a Family or as Add Other People?

#4 lingroot


  • Members
  • 22 posts
  • Gender:Male
  • Local time:11:21 AM

Posted 06 December 2016 - 10:32 PM

make all computers in same network group(let it be home group), give full permissions to drive that you need to share on each computer.

You can find those shared computers under network in windows file explorer.(check the fig)


Attached Files

Edited by lingroot, 06 December 2016 - 10:33 PM.

#5 Kilroy


  • BC Advisor
  • 3,479 posts
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:05:21 PM

Posted 07 December 2016 - 12:23 PM

I'll say again that a Network Attached Storage (NAS) or full server solution would be your best bet.


Since it doesn't seem like you have any cares about security you could map the machines C: drive administrative share on all of the machine.  This is about as sloppy as it gets, but works. If you know the Administrator account password for each machine you would create a batch file like this.




Where Computer# is replaced with the name of the computer and PASSWORD is the password for the Administrator account.  This will give everyone full access to the drive as if they were logged into the machine as Administrator.  I just verified that you can map your own C$ share, so you could use the same file for all four computers.  As I said, this is about as ugly as it gets, but it will work.

#6 Baron42


  • Members
  • 5 posts
  • Gender:Male
  • Location:California
  • Local time:03:21 PM

Posted 08 December 2016 - 03:13 PM

Kilroy that only works if the administrator account is enabled. Nowdays on decentralized networks the admin account is disabled. There are several things you need to do.


First off you need to turn off password protected sharing under the advanced sharing setting under the network sharing center. In the cortana box type control panel which will open the old win 7 style control panel. Click network and sharing center, then on the left click advanced sharing settings. Expand the Home or Work settings and set these items accordingly on all the computers.


1. Turn on Network Discovery

2. Turn on File and Print Sharing

3. Turn off password protected sharing


Next we want to enable the Administrator account and enable blank passwords. In the cortana box type gpedit.msc and hit enter. Under computer configuration \ Windows Settings \ Local Policies \ Security Options make these changes.


1. Accounts: Administrator account status Enabled.

2. Accounts: Limit local account use blank passwords to console logon only Disabled.


Now you need to create the shares on the systems that need it. Navigate to the folder you want shared, right click on it and select Share With -> Selected people. Click the drop down and select Everyone. Change the Everyone users rights to Read and Write. Now you can do as Kilroy says and use the net use command but it would be a little different.


net use x: \\computername\sharename


Thats all you need. Another way which might be easier for you is to open the file explorer and browse the network for the computer you want to gain access to its share. Click on the Computer then right click on the folder you want map and select Map Network Drive. The rest is easy step by set stuff. When the mapping is done, test it by adding a file to the share and then deleting it.

#7 baines77


  • Members
  • 34 posts
  • Gender:Male
  • Location:Washington, D.C.
  • Local time:06:21 PM

Posted 12 December 2016 - 01:56 PM

Turn off password protected sharing


^^this.  I spent an hour one time trying to get two PC's to talk that had previously been connected (and everything else was still set correctly) and the stupid tick box had been checked again....  

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users