Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need help getting a monitor to set at the correct resolution at boot.


  • Please log in to reply
4 replies to this topic

#1 Ravenbar

Ravenbar

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NY
  • Local time:06:38 PM

Posted 20 November 2016 - 07:36 PM

I've got a 3 monitor setup going on with an HP s52031(via VGA), an AOC TFT19W80PS(via DVI), and a Sylvania LC195SL9 A LCD TV(via HDMI).

 

The stock resolution of the TV is 1440x900. If I run it at that, the display area is much larger than the screen. I have to manually change the display to 1280x800 for it to be even closely correct, although the image is distorted slightly(stretched vertically).

 

I make the changes using (3) xrand commands:

xrandr --newmode 1280x800 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode HDMI-0 1280x800
 xrandr --output HDMI-0 --mode 1280x800

I have to do this every time I start the computer.

 

I attempted to add the commands to the rc.local file as root. The result wasn't as expected. When I booted the system the screen resolution was changed to 640x480.


Desktops: "John2" Custom, Gigabyte F2A88Xm-D3H, AMD 6A-5400K Trinity 3.6Ghz Dual-Core APU, 16Gb DDR3  HyperX Fury 1866Mhz RAM, 120Gb Crucial Force LS SSD OS) Linux Mint 17.3, 320Gb Raid1 array consisting of (1) Seagate ST320LT020-9YG14 & (1) Fujitsu MZH2320B

Francisco: HP pavilion p7-1080t upgraded with 16Gb ram. Windows 7. Used only for Gaming

Server.GaltsGulch: HP Elite 8300 Small Form Factor, i7-3770, 16Gb ram, Kingston SSDNow 120Gb SSD, 3Tb storage HDD, Fedora Linux/Avahi, Headless

 


BC AdBot (Login to Remove)

 


#2 Viper_Security

Viper_Security

  • Members
  • 826 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1
  • Local time:03:38 PM

Posted 20 November 2016 - 08:23 PM

If you're running a debian based distro, have you tried changing drivers in "Driver Manager"?

 

Assuming you know the refresh rate of your monitors, you have to add both resolutions of each monitor.

 

 

and if your max res is 1400x900:

 

"xrandr --newmode 1280x800 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync"

 

may not work because that, and correct me if I'm wrong but, that is telling xrandr to use the resolutions:  1368x768, 1440x771, 1576x781, and 1784x798 in it's range.

 

the 1400x900 resolution option isn't listed, you listed 798 as the max and not 900.

 

Try something similar to this.

 

xrandr --output LVDS --mode 1024x768 --rate 75

 

 

You may find this a good read.

 

https://wiki.ubuntu.com/X/Config/Resolution

 

Mint and ubuntu are debian based so it should work for a wide variety of Distros. 


Edited by Viper_Security, 20 November 2016 - 08:24 PM.

    IT Auditor & Security Professional

hQBT2G3.png


#3 Ravenbar

Ravenbar
  • Topic Starter

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NY
  • Local time:06:38 PM

Posted 20 November 2016 - 09:07 PM

If you're running a debian based distro, have you tried changing drivers in "Driver Manager"?

 

Assuming you know the refresh rate of your monitors, you have to add both resolutions of each monitor.

 

 

and if your max res is 1400x900:

 

"xrandr --newmode 1280x800 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync"

 

may not work because that, and correct me if I'm wrong but, that is telling xrandr to use the resolutions:  1368x768, 1440x771, 1576x781, and 1784x798 in it's range.

 

the 1400x900 resolution option isn't listed, you listed 798 as the max and not 900.

 

Try something similar to this.

 

xrandr --output LVDS --mode 1024x768 --rate 75

 

 

You may find this a good read.

 

https://wiki.ubuntu.com/X/Config/Resolution

 

Mint and ubuntu are debian based so it should work for a wide variety of Distros.

 

Using Mint17.2 with KDE.

 

Tried reading through that but its way over my head. I found those commands online somewhere months ago and they worked to get the maximized window size to the borders of the window.

 

I tried using the command:

xrandr --output HDMI-0 --mode  1440x900  --rate 59.9

 but I get a format not supported error from the monitor.

 

Monitor is currently at 59.9Hz per the Display Configuration GUI so the problem is the resolution. 

 

Dropping it back to 1280x800 using the above command got me back to where I was.


Edited by Ravenbar, 20 November 2016 - 09:15 PM.

Desktops: "John2" Custom, Gigabyte F2A88Xm-D3H, AMD 6A-5400K Trinity 3.6Ghz Dual-Core APU, 16Gb DDR3  HyperX Fury 1866Mhz RAM, 120Gb Crucial Force LS SSD OS) Linux Mint 17.3, 320Gb Raid1 array consisting of (1) Seagate ST320LT020-9YG14 & (1) Fujitsu MZH2320B

Francisco: HP pavilion p7-1080t upgraded with 16Gb ram. Windows 7. Used only for Gaming

Server.GaltsGulch: HP Elite 8300 Small Form Factor, i7-3770, 16Gb ram, Kingston SSDNow 120Gb SSD, 3Tb storage HDD, Fedora Linux/Avahi, Headless

 


#4 Viper_Security

Viper_Security

  • Members
  • 826 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1
  • Local time:03:38 PM

Posted 21 November 2016 - 02:37 AM

I had a similar issue on an iMacG4, it is quite annoying.

 

Open terminal and type in xrandr -q that will give you all the display modes available, if you do not see your resolution there continue on.

 

Try this in terminal:

 

cvt 1440 900 59.9        <-- that will give you the -hsync +vsync numbers.

 

Then you want to: xrandr --newmode "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync

 

where it shows "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624"  just copy the output of: cvt 1440 900 59.9

 

then do the: --addmode 1440x900_59.90 *** *** *** *** *** *** *** *** -hsync +vsync

 

as mentioned in: https://wiki.ubuntu.com/X/Config/Resolution#Adding_undetected_resolutions

 

 

Also look over this section: https://wiki.ubuntu.com/X/Config/Resolution#How_to_setup_a_dual_monitor

 

My apologies i should have referenced better in my previous post. 


Edited by Viper_Security, 21 November 2016 - 02:38 AM.

    IT Auditor & Security Professional

hQBT2G3.png


#5 Al1000

Al1000

  • Global Moderator
  • 8,054 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:38 PM

Posted 21 November 2016 - 10:38 AM

I have to do this every time I start the computer.


If the three commands work, and what you want to do is automate the process of changing resolutions that you currently carry out manually, a script in ~/.kde/Autostart should do the trick.

Open a terminal and change directory to .kde/Autostart:
cd ~/.kde/Autostart
Create a file. Here I'll use nano text editor, and call the file res-changer:
nano res_changer
Copy and paste these lines into the file in your terminal:
#!/bin/bash
sleep 3 && xrandr --newmode 1280x800 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode HDMI-0 1280x800
xrandr --output HDMI-0 --mode 1280x800
Save the file and close the text editor.
Make the file executable:
chmod +x ~/.kde/Autostart/res_changer
Now the screen resolutions should automatically change, 3 seconds after you log in. Vary the time interval depending on how fast your hardware boots the system by changing 'sleep 3' to 'sleep 1' or 'sleep 5' or whatever.

Edited by Al1000, 21 November 2016 - 10:41 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users