Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Extended Network with second router - get on some IP range


  • Please log in to reply
5 replies to this topic

#1 rjbathgate

rjbathgate

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:02 AM

Posted 16 November 2016 - 08:23 PM

Hi,

 

I have an Asus RT-AC68U router, which is creating my LAN on 192.168.1.XYZ

 

Then, at the end of a 100m cat6 cable in my garden office, I have a basic 4 port switch. That works fine.

 

However, it turns out I need more than 4 extra ports down here, and also WiFi extended, so I have set up an old / spare Netgear WNR2000 Router; connecting it from a port on the switch to the WAN port.

 

This has successfully created a new Wireless network, so all's "working"...

 

However, this new network and the Netgear WNR2000 is on a different subnet - 10.0.0.XYZ

 

So if I make use of the extra ports on the back of the Netgear -- however doing so means whatever device is connected with a 10.0.0.XYZ IP address... which means I cannot connect to it over the network from a 192.168.1.XYZ machine - i.e. I want to be able to set up a network shared drive from a device on connected to the Netgear, from a device connected the Asus, and vice versa.

 

The Netgear won't let me change it's IP range to 192.168.1.XYZ; returns the error "IP Address is conflicted with WAN IP Subnet"...

 

So... how can I either:

 

a) connect a device on 192.168.1.XYZ to a device on 10.0.0.XYZ (note, I'm using both Windows and Linux machines)

or

B) set up the Netgear so it's on 192.168.1.XYZ (or indeed the DHCP server it creates is on that range).

 

Thanks in advance

Rob



BC AdBot (Login to Remove)

 


#2 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:09:02 AM

Posted 16 November 2016 - 08:47 PM

Main thing is you want to use the LAN port and not WAN port on Netgear router.

 

Asus > CAT6 > Switch > CAT6 > Netgear LAN.

 

Also make sure it's in AP mode. This will make the Netgear pull IP's directly from the Asus router. This makes the Netgear part of the Asus network, and since they are they same network, you don't have to worry about routing them together. It will be automatic.

 

If you want to still be able to access the Netgear router to modify it, make sure it's web server IP (192.168.x.x.) is different then one to access the Asus router. IE 192.168.1.1 for Asus and 192.168.2.1 for Netgear. This won't effect the IP the Netgear gives out, just the IP you use to access it's web server (diagnostic UI).


Edited by Trikein, 16 November 2016 - 08:52 PM.


#3 rjbathgate

rjbathgate
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:02 AM

Posted 16 November 2016 - 09:37 PM

Hey

Thanks for the reply.

 

Looks like this router (WNR2000 V1) doesn't support AP mode; looking at http://kb.netgear.com/app/answers/detail/a_id/20927/~/how-do-i-change-my-netgear-router-to-ap-mode-after-i%E2%80%99ve-already-run-setup%3F?cid=wmt_netgear_organic there is no "AP Mode" at all, and it's running the latest firmware.

 

v2,v3 etc models seem to support it but looks like I have a v1.

 

Also followed this:

https://community.netgear.com/t5/Wireless-N-Routers/How-to-use-WNR2000-as-an-access-point/td-p/301555

 

But as per point 2, there is no "Access Point IP" on the LAN settings page.

 

Guessing this means I need new hardware?



#4 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:09:02 AM

Posted 17 November 2016 - 12:30 AM

I wouldn't use the word "need" but It would certainly make things a lot easier/better. Try connecting the ethernet from the switch to the Netgear's LAN port and then disable the DHCP server as per page 4-4 in manual, and see what works and what doesn't. The wild card is how the firewall will act in that configuration.

 

You could create two subnets and then create a static route between them, but that won't be easy and might cause problems with network discovery and file sharing.  This is similar to your idea in OP. However, it's better to have the netgear do as little as possible and just have it handle the physical side of the connection and have all the processing done in the newer Asus router. 

 

Last, if your WNR2000 is V2 and above, you could flash dd-WRT on it which would give it a AP mode. See here for some general instructions on dd-WRT and here are ones specific to setting it up in AP mode.



#5 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:07:02 AM

Posted 17 November 2016 - 06:49 PM

Here is a tutorial on how to setup two routers in the same subnet so everyone can see each other

 

http://www.techsupportforum.com/3001-connecting-additional-routers/



#6 rjbathgate

rjbathgate
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:02 AM

Posted 17 November 2016 - 06:52 PM

Hey

 

Thanks all for the replies.

 

Solved the issue by finding (forgot I had it!) a larger switch :-)

 

Ta






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users