Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I can't share internet to client computers. Tried everything.


  • Please log in to reply
4 replies to this topic

#1 Alchael

Alchael

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:08 AM

Posted 10 November 2016 - 01:59 AM

EDIT: This is a cross-post from techsupportforum http://www.techsupportforum.com/forums/f31/i-cant-share-internet-to-client-computers-tried-everything-1166633.html I have no intention of wasting anyone's precious time, I am just getting desperate for answers since I've been stuck with this for more than a week now. I will update both threads on the two forums regarding its status. I hope you understand.

-------------

Hi everyone in bleepingcomputer, I'm a newbie here so please bear with me.
I have this home network which I setup. Basically what I want to achieve is to share my server pc internet connection (connected wireless to the modem/router) to my client computers via a switch. What should I do? What parameters should I set my NIC cards (IP,subnet,gateway,dns) so that my server pc internet gets shared to the clients and designating the server pc as the dhcp server instead of the router because I want to be able to control the client's bandwidths. I've tried Internet Connection Sharing and it didn't work. I've also tried bridging the two NICs together and still it didn't work... the clients can connect to the server pc and they can ping it properly but they cannot access the internet. By the way my router's private IP is 192.168.1.1.
This is my topology:

 

topography_1.jpg

 

My server and client operating systems are Windows 7 Ultimate 64-bit SP1 with modern (2016) hardware. The modem/router I'm using is a Huawei B593s-22 LTE CPE Broadband Wireless router with 4 physical ports. My server is roughly 5 meters away from the router and the router is connected to the ISP using LTE (I think it's using 4G if I'm not mistaken) to connect wirelessly to a nearby cellphone tower, it's got around 2MBps internet speed - I know it sucks but it's all we got in our area right now.

 

This is my current setup: I set my server LAN NIC to obtain IP and DNS server address automatically and also set the Wifi NIC to obtain IP and DNS server address automatically from the router, this time the dhcp in the router is enabled as I want to test ICS functionality (the dhcp in the router is set to give 192.168.1.100 as the first IP up to 192.168.1.200 subnet used is 255.255.255.0). Upon enabling ICS in the Wifi NIC, the LAN NIC automatically gets the IP address of 192.168.137.1 and subnet 255.255.255.0 with nothing on default gateway and dns servers. Going with this configuration the clients talked to the server fine and can even do file exchanges between the two but they have no internet connection, only the server has internet. This is the result of ipconfig /all:
 

Windows IP Configuration
 
   Host Name . . . . . . . . . . . . : CyphernetServer
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : homerouter.cpe
 
Wireless LAN adapter Wireless Network Connection:
 
   Connection-specific DNS Suffix  . : homerouter.cpe
   Description . . . . . . . . . . . : TP-LINK Wireless USB Adapter
   Physical Address. . . . . . . . . : 18-A6-F7-1F-6F-F2
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::6471:6c68:6b62:5d06%13(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Thursday, November 10, 2016 2:09:36 PM
   Lease Expires . . . . . . . . . . : Friday, November 11, 2016 2:09:36 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 303605495
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-A3-DA-F6-70-8B-CD-A2-AD-F2
 
   DNS Servers . . . . . . . . . . . : fe80::d22d:b3ff:fe18:64ce%13
                                       192.168.1.1
                                       192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled
 
Ethernet adapter Local Area Connection:
 
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel® Ethernet Connection (2) I219-V
   Physical Address. . . . . . . . . : 70-8B-CD-A2-AD-F2
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled
 
Tunnel adapter isatap.homerouter.cpe:
 
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : homerouter.cpe
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
 
Tunnel adapter isatap.{9886929A-2C28-4BB3-A2FB-83C412BADA5B}:
 
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
 
Tunnel adapter 6TO4 Adapter:
 
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Edited by Alchael, 10 November 2016 - 03:29 AM.


BC AdBot (Login to Remove)

 


#2 Stancestans

Stancestans

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:08 AM

Posted 10 November 2016 - 02:55 AM

Kindly do not post the same issue on multiple forums (cross-posting). Your problem is already being addressed at Tech Support Forum here http://www.techsupportforum.com/forums/f31/i-cant-share-internet-to-client-computers-tried-everything-1166633.html. Many other people like myself are members of both forums and I'm split between responding to this thread or the one at TSF, so you can see why cross-posting is not advisable. For cross-posting ettiquette, please read http://www.excelguru.ca/content.php?184


Edited by Stancestans, 10 November 2016 - 02:56 AM.


#3 Alchael

Alchael
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:08 AM

Posted 10 November 2016 - 03:13 AM

Sorry for cross-posting, I was not aware there was some kind of etiquette that's being imposed upon such practice and I was not aware of my actions and intended no harm. Rest assured I have no mal-intentions and yes I posted this on techsupportforum last night and I'm a newbie on both forums. I have resorted to getting help online because I'm stuck in this problem for more than a week now to no avail. I would not ask for help if I was able to figure this out on my own. I will take responsibility of my actions and I apologize for cross-posting because I was not even aware that such a thing is looked down upon. Rest assured I have no intention of wasting people's time on both forums and I will update its status until it gets solved as to not waste anybody's time. Thank you for pointing out my mistake.



#4 Alchael

Alchael
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:08 AM

Posted 10 November 2016 - 01:20 PM

Thank you everyone for your help. I was able to solve it by my own. It was my fault I didn't state firsthand that I was using a diskless setup for the client PCs. There was something wrong with the image that I first uploaded and I had to rebuild from scratch and that solved everything. Somebody please mark this thread as SOLVED. Thanks.



#5 Stancestans

Stancestans

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:08 AM

Posted 26 November 2016 - 05:45 AM

Sorry for cross-posting, I was not aware there was some kind of etiquette that's being imposed upon such practice and I was not aware of my actions and intended no harm. Rest assured I have no mal-intentions and yes I posted this on techsupportforum last night and I'm a newbie on both forums. I have resorted to getting help online because I'm stuck in this problem for more than a week now to no avail. I would not ask for help if I was able to figure this out on my own. I will take responsibility of my actions and I apologize for cross-posting because I was not even aware that such a thing is looked down upon. Rest assured I have no intention of wasting people's time on both forums and I will update its status until it gets solved as to not waste anybody's time. Thank you for pointing out my mistake.

It's all good. We all have a first time for everything. It would be an injustice if i hadn't shown you the error of your ways now, wouldn't it? Welcome to both forums! :)

Anyway, I'm glad to hear your problem has been resolved. You have to mark the thread as solved yourself, I'm afraid. I believe that option is only available to you, the starter of the thread, but I could be wrong.


Edited by Stancestans, 26 November 2016 - 05:45 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users