Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wired PC to PC connection using Ethernet?


  • Please log in to reply
23 replies to this topic

#1 DGDanforth

DGDanforth

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 02 November 2016 - 09:53 PM

I am unable to get my Windows XP machine to communicate with my Windows 10 machine.

Details:

Machine A: MacBook running Windows XP using Parallels Desktop for Mac.

Machine B: HP laptop computer running Windows 10.

 

I have set up both machines to belong to the same group "HOME" (without quotes).

An Ethernet crossover cable is plugged into each machine.

I use machine A to initiate connection to machine B.

I watch machine B's network and see that (after a 10 second delay) bytes are indeed being

received and that a few bytes are being sent.

But machine A then says it can not connect.

 

I don't know what each machine expects in the way of handshake.

What should that be?

 

-Doug Danforth


Edited by hamluis, 06 November 2016 - 07:24 PM.
Moved from XP to Networking - Hamluis.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:12 AM

Posted 03 November 2016 - 08:27 AM

FWIW

 

Louis



#3 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 03 November 2016 - 07:22 PM

After playing around (too many parameters to say) my XP now says the LAN is connected.

Again bytes are exchanged between the machines (as viewed from both machines) but

neither machine shows the existence of the other in its devices or folders.

I have read the FWIW topics and they do not address the visibility of the remote

machine.  How do I get XP to show me the Windows 10 folders and how do I get

Windows 10 to show me the XP folders?  I have tried the obvious solutions.

-Doug



#4 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,016 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:09:12 AM

Posted 05 November 2016 - 05:14 PM

 

I have tried the obvious solutions.

 

Have you set the folders you want to see on each computer to 'Share' in the folder properties box ?

 

Chris Cosgrove



#5 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 05 November 2016 - 07:52 PM

I had not done that but now I have set sharing on the files for both the MAC and HP machines.

I still don't see any files.

The MAC does say that HP is now connected.

WHERE should I see the other machines files?

On the HP (Windows 10) machine ThisPC->Devices and drives does not show the MAC machine.

The MAC status window shows that the HP has sent 21,000 and received 34,000 bytes.

The HP Status on the MAC says it has sent 985 and received 719 bytes so there is a miss match.

What now?

-Doug



#6 ACupOfCoffee

ACupOfCoffee

  • Members
  • 18 posts
  • OFFLINE
  •  

Posted 06 November 2016 - 10:43 AM

Have you set static IP addresses on both machines and the correct subnet? I know you said you tried the obvious stuff, but I have no way of knowing what you would consider obvious.

#7 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 06 November 2016 - 06:41 PM

I have not set static IP addresses for I do not know the values to which they should be set.

I know the subnet value but what should the numbers be for the two machines?



#8 ACupOfCoffee

ACupOfCoffee

  • Members
  • 18 posts
  • OFFLINE
  •  

Posted 06 November 2016 - 06:56 PM

It's usually 192.168.0.xxx, where the x is whatever you want, but it doesn't matter that much what it is.

#9 hamluis

hamluis

    Moderator


  • Moderator
  • 56,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:12 AM

Posted 06 November 2016 - 07:23 PM

If you are using DHCP...you should not employ static IPs.

 

Louis



#10 ACupOfCoffee

ACupOfCoffee

  • Members
  • 18 posts
  • OFFLINE
  •  

Posted 06 November 2016 - 07:31 PM

The couple times I've done this, admittedly not with a VM involved, I disabled DHCP.

#11 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 06 November 2016 - 08:45 PM

Default gateway?

 

I forgot to mention that on my XP system I was able to get my Network Places to see the HP machine

BUT when I attempt to open it says I don't have permission,

I thought I had given shared access to the folder but it seems to (maybe) want a password but

there is no fill in field asking for the password.  How do I get this to work?

 

"\\Dgdhp\c is not accessible.  You might not have permission to use the network resource  Contact the administrator of this server to find out if you have access permissions,

 

The network path was not found.

"

 

I am the administrator of both  machines.

 

-Doug


Edited by DGDanforth, 06 November 2016 - 08:50 PM.


#12 ACupOfCoffee

ACupOfCoffee

  • Members
  • 18 posts
  • OFFLINE
  •  

Posted 06 November 2016 - 09:13 PM

Now we're getting somewhere! Sharing has gotten way more advanced since XP and a lot of the security features available in newer Windows versions just aren't compatible with it. We basically have to dumb 10 down to XP's level. This is what advanced sharing settings should be changed from defaults. Password protected sharing should be off. Public folder sharing should be on. Use user accounts and passwords to connect to other computers should be selected. Now disable any homegroup that may have been created. Make sure the folders are set to be shared with Everyone.

#13 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 06 November 2016 - 10:06 PM

I did as suggested.  Same result.  Can't access.

I had to restart the Windows 10 machine to have the changes take effect (as they suggested).

 

I double checked the sharing options for the destination folder and everything is allowed.

 

Now what?


Edited by DGDanforth, 06 November 2016 - 10:07 PM.


#14 ACupOfCoffee

ACupOfCoffee

  • Members
  • 18 posts
  • OFFLINE
  •  

Posted 06 November 2016 - 10:16 PM

Is "Everyone" listed in the sharing permissions? When you give users, administrators, and guests sharing access those refer to groups of users on that particular computer. Everyone is the only group that would include non local users.

#15 DGDanforth

DGDanforth
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:12:12 AM

Posted 06 November 2016 - 10:27 PM

Now I have to find where the damn "Everyone" check box is!

I saw it in the past and did have it selected but it  may not be now.

Windows 10 seems to be "context sensitive" and doesn't always

so me the same things when I revisit.

Grumble ... hang on.

 

Also, how do I turn off HomeGroup?  It says I was invited to it, but by whom?

I don't see an option to  disable it.


Edited by DGDanforth, 06 November 2016 - 10:39 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users