Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Force Home network?


  • Please log in to reply
11 replies to this topic

#1 aromack

aromack

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 31 October 2016 - 05:08 AM

Is there a way to force windows to only use Home Network and never Public?  Every time I reboot my computer I have to manually go into network and share center and switch network to Home Network because it defaults every time to Public Network.

 

Perhaps a way to wipe out the entire windows networking component and reinstall it without reinstalling the entire OS?

 

Windows 7 x64 sp1



BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:03:02 PM

Posted 01 November 2016 - 12:20 AM

Go into services (type services.msc in the run box) find the NLA service and change the startup to Automatic (delayed start). This should delay the startup of the Network Location Awareness service long enough for your computer to have an IP address.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#3 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 01 November 2016 - 11:44 AM

Awesome! I will give this a try. I will report back with what happens.

 

Thank you


Edited by aromack, 01 November 2016 - 11:44 AM.


#4 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 02 November 2016 - 12:56 PM

After many many days of google searching for this issue,

 

Go into services (type services.msc in the run box) find the NLA service and change the startup to Automatic (delayed start). This should delay the startup of the Network Location Awareness service long enough for your computer to have an IP address.

 

This is what finally solved the problem!   Thank you so so much!



#5 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:03:02 PM

Posted 02 November 2016 - 08:50 PM

You Are very Welcome  :thumbup2:


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#6 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 14 November 2016 - 01:32 PM

Some how this issue has reared it's ugly head once again. I double checked ot make sure NLA was delayed start and it still was. But the system is back to starting up in public network mode instead of private/home network.



#7 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:03:02 PM

Posted 15 November 2016 - 09:22 PM

If you disable, then re-enable the network adapter does the network change to private?
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#8 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 11 December 2016 - 07:17 PM

No, every time I do anything network related that makes me reconnect to my wireless router it always defaults to public forcing me to manually change it back to Home network. I have tried all kinds of things, I even went into gpeditor and changed some policies to try and force private not public but that did nothing. I also tried this (after backing up my system).

 

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles]
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Managed]
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Unmanaged]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Managed]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Unmanaged]

 

To try and start from scratch.


Edited by aromack, 11 December 2016 - 07:20 PM.


#9 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:03:02 PM

Posted 12 December 2016 - 01:19 PM

What are you using for antivirus? What IP are you using for DNS (your ISP? Google Public, open DNS, Level 3, etc..)? Does this only happen on wireless? What happens if you connect directly with a LAN cable? What is the make and model of the wireless card?


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#10 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 15 December 2016 - 11:14 PM

I use avast internet security 12.3.2280, My system is dhcp from the router.  but in the 192.168.10.xxx range.  My from my router to ISP I have dedicated ip address.  The adapter is a cisco am10.  No way for me to connect directly to my router, I have no cable long enough. This is a desktop full tower pc.

 

I just noticed that tonight the it keeps changing back to public even though I have not lost connection to my router at all. I have literally had to manually change it to private 5 times today.


Edited by aromack, 16 December 2016 - 03:41 AM.


#11 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:03:02 PM

Posted 16 December 2016 - 08:51 PM

What group policy did you change? Was it this one?

network-location-2-gpo.jpg

 

 

Edit: Also try disabling Secure DNS in avast


Edited by Sneakycyber, 16 December 2016 - 08:56 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#12 aromack

aromack
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:02 AM

Posted 17 December 2016 - 04:22 PM

I actually did not change that one, unidentified networks is on public.  But I did change the one that lists my network name to be private.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users