Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 10 Turn on File and Printer Sharing


  • Please log in to reply
13 replies to this topic

#1 jwells02

jwells02

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 10:07 AM

I'm trying to setup a new computer on my office network and can't enable file and printer sharing. I've tried a lot of things I've found in the posts on this site but no luck. When I click Turn on File and Printer Sharing and save it doesn't give me the expected requester confirming I want to make the change but just closes out normally. When I go back to check it it is unchecked again. I've spent two days trying to find the answer. A lot of posts made reference to issues with the firewall. I had McCaffee which I eventually uninstalled after so many attempts with the settings to use the windows firewall. Didn't work. I shut down Windows Firewall and defender just to see if it might be that and I have the same thing. I'm really stuck now hopefully someone can help.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:42 AM

Posted 28 October 2016 - 11:38 AM

Have you tried the method in Option 3 shown here? Make sure the box next to File and Print Sharing is checked. If File and Print Sharing is not listed then you will need to install it though I don't know why it would not be listed.



#3 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 12:50 PM

I went back and double checked that and it is checked.



#4 JohnC_21

JohnC_21

  • Members
  • 24,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:42 AM

Posted 28 October 2016 - 01:14 PM

If Network Discovery is enabled see if you can enable File and Print sharing in the hidden Administrator Account

 

Open an elevated command prompt by pressing the Windows key + X and selecting cmd as admin. Type

net user administrator /active:yes

Login to the now enabled administrator account and try enabling file and print sharing. If clicking the option does not work then try Option 2 in my link and to enable via a command prompt.

 

If none of above solves the problem I would PM a moderator and ask that the thread be moved to the Networking Forum where somebody with Networking experience can give some additional ideas. Can you detect other computers on the network? 



#5 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 01:42 PM

I will go try this. I'm trying to setup a NAS drive. I can access it fine from other computers on the network except this one. I can ping it but it won't let me access it. I believe it may be caused from not being able to change this setting however I can see other computers on the network.



#6 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:42 AM

Posted 28 October 2016 - 01:47 PM

If your Windows 10 computer or device can’t view other computers on the network, two things are probably not correct: 
  1. You either assigned the incorrect network profile (public instead or private) 
  2. or network discovery is turned off for some reason.
In addition, you need to set up to start automatically
  1. Peer Name Resolution Protocol
  2. Peer Networking Grouping
  3. Peer Networking Identity Manager
If this all is correct and running, must be some especial problem, which don't allow sharing.


#7 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 02:03 PM

JohnC - I tried the first one and it said it executed successfully. Checked it and it was off. Tried to change it and it would not change. Tried Option two. It said something like updated or created 47 new rules. Went back and it was unchecked. Checked it but still won't save.

 

kaljukass - it was public before and had a hard time changing it to private but it has been on private since. Network Discovery has always been on. The three Peer services were not running. I started them and changed them to automatic but still no go. I can see the other computers on my network but it says I may not have permission to access them.



#8 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 02:08 PM

Also in the message box about may not have permission on the bottom is say 'Network is not present or not started'.



#9 JohnC_21

JohnC_21

  • Members
  • 24,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:42 AM

Posted 28 October 2016 - 02:14 PM

This is starting to get out of my experience level regarding networking. Client for Microsoft Networks is checked under Option 3 of my previous link, correct?



#10 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 02:30 PM

yes it is checked.

 

The Workstation service is not running. When I tried to run it failed said the dependencies were not running. One wasn't so I started it but it still fails saying a dependency is not running although they all appear to be. From what I've read this service has to be running.



#11 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:42 AM

Posted 28 October 2016 - 02:49 PM

...

The three Peer services were not running. I started them and changed them to automatic but still no go.

I can see the other computers on my network but it says I may not have permission to access them.

You do not have permission before you got it from other computer administrator. Now you have to apply for the right to receive from them a password, this password what they got if they set up sharing. The same is if set up homegroup. Every user has its own password, what they can share to those, whom they want and also they can at any time to change this password  and if they want to share it to You, You must get it and log in using this new password. 
So, if You already see the others, then is everything ok, but now must other do the same or they must be joined with Your sharing centre and they must be logged in with with Your password. Only then You can use these materials, which are there available and shared so, that You have permission see and use them.


#12 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 02:56 PM

When I've done this with other computers it asked me for the login and password which worked fine. This time it says 'Network is not present or not started'. which is strange because I can see them.



#13 jwells02

jwells02
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 28 October 2016 - 03:31 PM

Resolved - workstation service would not start because of issues with dependencies I could not resolve. I found a site that suggested I could have a bad system file so I did a system file scan. It came back all good.

 

The next step was in a admin cmd type: sc config mrxsmb20 start=demand

 

I then rebooted and now the network is running great. Here was the link: http://answers.microsoft.com/en-us/windows/forum/windows_10-networking/cannot-start-the-computer-browser-and-workstation/0c00ec0b-153a-4e60-9642-d322174f4b60



#14 JohnC_21

JohnC_21

  • Members
  • 24,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:42 AM

Posted 28 October 2016 - 03:32 PM

Nice. Thanks for posting the solution and link.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users