Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

vsftpd 3.0.3 install \ config on RHEL 6.x


  • Please log in to reply
5 replies to this topic

#1 2016hp

2016hp

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:04 AM

Posted 28 October 2016 - 01:45 AM

PLEASE HELP
 
I have downloaded the vsftpd 3.0.3 software from https://security.appspot.com/vsftpd.html
 
I have followed the INSTALL file but its not working as described
 
I need to set it up as a FTPS server
 
I need like a "ELI5" installation guide 

Edited by hamluis, 28 October 2016 - 03:33 AM.
Moved from All Other Apps to Linux/Unix - Hamluis.


BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 8,026 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:04 AM

Posted 28 October 2016 - 05:11 AM

Hi,

Isn't vsftpd available in the repositories for your distro?

You might find some helpful info here:

https://www.linux.com/blog/install-and-configure-ftp-server-redhatcentos-linux

http://www.wikihow.com/Set-up-an-FTP-Server-in-Ubuntu-Linux

Edited by Al1000, 28 October 2016 - 05:29 AM.


#3 2016hp

2016hp
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:04 AM

Posted 31 October 2016 - 12:38 AM

Hello

Question > When installing vsftpd via the Red Hat Enterprise Linux 6.5 package manager it installs vsftpd v2.2.2 [7 year old version] .... The latest version according to https://security.appspot.com/vsftpd... is vsftpd v3.0.3 [2015]

So if I install vsftpd v2.2.2 via RHEL 6.5 package manager how do I upgrade to v3.0.3 ?



#4 Al1000

Al1000

  • Global Moderator
  • 8,026 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:04 AM

Posted 31 October 2016 - 04:57 AM

The latest version might not be supported by your distro.

FYI, the available version of vsftpd in Kubuntu 14.04 (which I happen to be using) repositories is 3.0.2 - so will be the same in other *buntu 14.04 versions.

I've never used Red Hat but have heard that it tends to use older packages, whereas *buntu uses the "latest" stuff. It looks like this is an example of that.

Is there a specific reason why you want the latest version?

Edited by Al1000, 31 October 2016 - 04:58 AM.


#5 2016hp

2016hp
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:04 AM

Posted 01 November 2016 - 03:44 PM

I need to setup vsftpd on a RHEL 6.5 box and was just wonder how I can install the latest version ... I guess I will have to stick to 2.2.2 ... Thx for the help



#6 Al1000

Al1000

  • Global Moderator
  • 8,026 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:01:04 AM

Posted 01 November 2016 - 05:57 PM

Some distros deliberately use older packages for stability. If 2.2.2 does everything you need it to do, that would certainly be the easiest option.

Hope it all goes well.

Edited by Al1000, 01 November 2016 - 05:57 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users