Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mint 18 - issue with restarting.


  • Please log in to reply
9 replies to this topic

#1 Graeme308

Graeme308

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:10:38 AM

Posted 23 October 2016 - 07:28 PM

Hi,

 

Can anyone tell me why Mint restarts itself approx 5 seconds after I shut it down. This happens every second time. Not intermittently, not every time, not occasionally, but every second time without fail. It used to happen with 17.2 and I thought it would stop when I did a fresh install of Mint 18, but no, it still does it.

As soon as I see the power light on the case come back on I hold down the power button to shut it down. I am used to doing this by now, but it’s probably not doing the hard drive any good. I have searched for answers in the past, but never seemed to find a similar situation.

 

This is on my desktop only. I have Mint 18 running on a laptop (which I installed over the top of windows 10) and it doesn’t do it. I also have 17.1 running on an old laptop and it has never done it.

 

The specs are – Mint 18 Cinnamon 64 bit / i5-4570 CPU / 8GB ram / WD Velociraptor 500GB / Radeon HD7870 graphics.

 

As I said, I have got used to manually shutting it down every second time, but I am curious as to why it is doing it. Any ideas?

 

Thanks,

Graeme



BC AdBot (Login to Remove)

 


#2 pcpunk

pcpunk

  • Members
  • 6,259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:07:38 PM

Posted 23 October 2016 - 09:09 PM

I was having this issue on a new install of Mate 18 on a customers laptop today.  I was too busy to worry about it, but will evaluate it as soon as I get back over there, maybe tomorrow.  I think it re-started to the Log-in, and you can use the Little Power Shutdown in the upper right hand corner, I think, hope that helps.  I've had many little issues with my linux installs because I thrash the heck out of them, never had any adverse affects from a Forced Shutdown...so far.  Not that happy with Mint 18 so far, and knew I should have installed 17.3 for now.  It's an older lappy 2010, and I usually tell folks not to install 18 just for this reason, but, it's an all intel based laptop and was in such great shape the age kinda got away from me and went against my own advise.  I'll get back ASAP and fill you in on what I find.

 

pc


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#3 pcpunk

pcpunk

  • Members
  • 6,259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:07:38 PM

Posted 24 October 2016 - 12:43 PM

The specs are – Mint 18 Cinnamon 64 bit / i5-4570 CPU / 8GB ram / WD Velociraptor 500GB / Radeon HD7870 graphics.

I would be very interested to see all your specs if you don't mind.  It may be helpful or interesting to see if there is a similarity, although I'm working with a Laptop and you a desktop.  Here are the Specs for the offender below.

 

Spoiler

 

pc


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#4 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,721 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:11:38 AM

Posted 24 October 2016 - 04:19 PM

 

I would be very interested to see all your specs if you don't mind.  It may be helpful or interesting to see if there is a similarity

What would be the point?

 

Why do I get a reboot instead of a shutdown?

 

Shutdown = Restart (ie.. Mint 14 will not shut down) - Linux Mint ...


Edited by NickAu, 24 October 2016 - 04:19 PM.


#5 Graeme308

Graeme308
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:10:38 AM

Posted 24 October 2016 - 05:39 PM

Good morning NickAu,

 

Thanks for the links, but reading through the posts on them, I can't see anyone mentioning that their machine (laptop or desktop) is doing what mine does - restarting every 2nd shutdown.

It will shut down normally, then the next time I use it and shut it down, it will restart. The shutdown after that will be normal, then the next a restart, and so on. It did it when I had mint 17.2 on this machine, and does the same now with a clean install of Mint 18.

As I said, I am just curious as to why it is doing it.

 

You say there is no point in seeing my specs, but pcpunk did ask for them, so no offense to you, but here they are:

System: Host: Kernel: 4.4.0-21-generic x86_64 (64 bit)

Desktop: Cinnamon 3.0.7 Distro: Linux Mint 18 Sarah

Machine: System: Gigabyte product: G1.Sniper B5

Mobo: Gigabyte model: G1.Sniper B5-CF v: x.x

Bios: American Megatrends v: F5 date: 08/03/2013

CPU: Quad core Intel Core i5-4570 (-MCP-) cache: 6144 KB

clock speeds: max: 3600 MHz 1: 3582 MHz 2: 3600 MHz 3: 3589 MHz

4: 3597 MHz

Graphics: Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller

Card-2: Advanced Micro Devices [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]

Display Server: X.Org 1.18.3 drivers: ati,radeon,intel (unloaded: fbdev,vesa)

Resolution: 2560x1440@59.95hz

GLX Renderer: Gallium 0.4 on AMD PITCAIRN (DRM 2.43.0, LLVM 3.8.0)

GLX Version: 3.0 Mesa 11.2.0

Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller

driver: snd_hda_intel

Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller

driver: snd_hda_intel

Card-3 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]

driver: snd_hda_intel

Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic

Network: Card: Intel Ethernet Connection I217-V driver: e1000e

IF: eno1 state: up speed: 100 Mbps duplex: full mac: 74:d4:35:82:85:c5

Drives: HDD Total Size: 500.1GB (11.9% used)

ID-1: /dev/sda model: WDC_WD5000HHTZ size: 500.1GB

Partition: ID-1: / size: 450G used: 48G (12%) fs: ext4 dev: /dev/dm-0

ID-2: /boot size: 473M used: 61M (14%) fs: ext2 dev: /dev/sda2

ID-3: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1

RAID: No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 32.0

Fan Speeds (in rpm): cpu: N/A

Info: Processes: 193 Uptime: 13 min Memory: 882.5/7856.2MB

Client: Shell (bash) inxi: 2.2.35

 

Sorry, but I don't know how to hide them like he did with his.



#6 Viper_Security

Viper_Security

  • Members
  • 826 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1
  • Local time:05:38 PM

Posted 24 October 2016 - 06:19 PM

Are you by chance using the "Microcode Processor Driver" under "Driver Manager"?

 

and which video driver are you using?


Edited by Viper_Security, 24 October 2016 - 06:20 PM.

    IT Auditor & Security Professional

hQBT2G3.png


#7 Graeme308

Graeme308
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:10:38 AM

Posted 24 October 2016 - 06:52 PM

Driver manager shows I am not using "Microcode Processor Driver"

 

According to lshw -c video, I am using the radeon driver.



#8 Viper_Security

Viper_Security

  • Members
  • 826 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1
  • Local time:05:38 PM

Posted 24 October 2016 - 06:59 PM

Okay.

 

And have you tried:

 

sudo apt-get -f install

sudo apt-get autoclean

sudo apt-get autoremove

sudo apt-get clean

sudo apt-get update

 

-----------------------------------------------

 

and if you want to upgrade your OS (there may be a bug in the version you have that later release have fixed)

sudo apt-get update && sudo apt-get dist-upgrade


    IT Auditor & Security Professional

hQBT2G3.png


#9 Graeme308

Graeme308
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:10:38 AM

Posted 24 October 2016 - 07:25 PM

Thanks for the advice, but still doing it.

 

Tried all those, shut it down a few times, and it is still restarting every second time.

 

As for upgrading the OS, it did exactly the same thing on this machine when it was running a previous version of Mint (17.2) And I have a laptop running Mint 18 (installed from the same image that I used on this) with no problems at all.



#10 pcpunk

pcpunk

  • Members
  • 6,259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:07:38 PM

Posted 24 October 2016 - 10:04 PM

Read through this post, there are a few things you can try without modifying any files.  "Disable Wake on LAN", and another had success with:

 

"Thought it might be a USB related wake. Used non USB mouse and keyboard and problem solved." 

and

"One of my colleagues suggested that, though mine was a desktop PC, I should install laptop-mode-tools, and surprisingly it worked!

 

http://askubuntu.com/questions/452750/reboot-after-shutdown-ubuntu-14-04-also-12-04-dell-latitude-e7440

 

Use at own risk, I have not tried any of these yet, and don't know if our issues are the same at this point.

 

Here is a bug report that looks relevant

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1346269

 

pc


Edited by pcpunk, 24 October 2016 - 10:05 PM.

sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users