Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Keyboard(PS2) not working in Bios menu and Boot selection menu.

  • Please log in to reply
3 replies to this topic

#1 IGN_Kiran


  • Members
  • 2 posts
  • Gender:Male
  • Location:Gujarat, India
  • Local time:06:26 AM

Posted 23 October 2016 - 10:20 AM

Hello world, I am Kiran.

     As you can see in title i have a problem i am finding solution for 2 days by now. Found many suggestion on what to do on youtube, yahoo answers and many other alternate sites but unfortunately there was no solution for me, i mean i am beginner as compared to many people on this forum and i think there are many thing i haven't tried yet as i know this forum can suggest it.

     Problem is i am not able to navigate or perform any operation in bios once i am there. its weird since if my keyboard wasn't supposed to work in bios i shouln't even able to get there by pressing Del key in the first place; or f12 for boot selection menu. from the menu it like froze up there. it works fine in windows ones i m in, or within that f8 key operations that brings up several options and safe mode during startup. so its only not working in cmos/bios munu snd boot selection.
here's the Detail of hard ware:   

     1. gigabyte motherboard model:g31m-es2l
     2. logitech ps2 keyboard

     3. not necessary i think (core2 duo, ddr2 2 gb X2 RAMs, 2gb Nvidea grafics)


     Things i've already tried:

1. clear cmos by jumper

2. changed cmos battery(since it was depleted after 1 yr of no use)

3. tested with another ps2 keyboard

4. updated bios from gigabyte online services 2 times

5. removed viruses lol and still cleaning

6. countless time pc restart by pressing buttons that was supposed to cure problem

but nothing worked for me so far, i need to solve this problem for i am about to install windows newer version.
anything you say i will try it again if i have to, thanks for your time :)

Edited by hamluis, 23 October 2016 - 10:58 AM.

BC AdBot (Login to Remove)



#2 hamluis



  • Moderator
  • 55,038 posts
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:56 PM

Posted 23 October 2016 - 10:58 AM

If your system currently has a malware problem/situation...this is not the correct forum for such.


Any issues that the system has developed...may be related to malware.  Rather than start a million topics for emerging symptoms...let's see if we can neutralize the malware aspect and then go on to whatever issues may appear.


Moved topic to Am I Infected forum.



#3 IGN_Kiran

  • Topic Starter

  • Members
  • 2 posts
  • Gender:Male
  • Location:Gujarat, India
  • Local time:06:26 AM

Posted 24 October 2016 - 12:27 AM

Thanks @Louis for your suggestion, I understand you have read my whole post and moved it to malware section. But You see it was only one possibility of many, therefore i didn't give it higher priority than other possible causes. and excuse me for any inconvenience caused by my lack of ability for selection of forum type/genre.  


Anyway here's my latest update on my problem:


1. i Got CMOS error at startup and it loaded default setting. As i mentioned i replaced my CMOS battery to a new one so what might causing it, and is it related to my main(keyboard) problem. i upgraded bios but then i restarted PC.


2. it has anything to do with my graphics card, i mean if i remove it then it might work.


3. or is it simply a malware? and if i am able to format my PC then can problem be solved but then again i cant use my keyboard.


Its confusing really, but again i will try any suggestion provide in this forum. thanks.

#4 JohnC_21


  • Members
  • 22,149 posts
  • Gender:Male
  • Local time:08:56 PM

Posted 28 October 2016 - 08:38 AM

Do you have an available USB keyboard to try?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users