Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

File Ownership and right of access


  • Please log in to reply
3 replies to this topic

#1 LucasAlmeida

LucasAlmeida

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:13 PM

Posted 18 October 2016 - 11:17 AM

Hello, community

 

I posted another topic in another section of the forum, but since this is an unrelated question, I hope it's alright to post again.

 

I upgraded from XP to Win10 64 Pro through a clean stall. Since then, I've been having problems with the UAC, which I already turned down completely

In all my hard drives and folders, I changed the "ownership" to my user, instead of the default "trusted installer", and my account have administrative rights, but even then I still get the "you don't have administrative rights" when trying to open a folder in another hard drive or even in the system files (which I already enabled on folder options). Another thing that happens is that I have music in another hard drive which Windows Media Player cannot play.

The workaround that solves all these issues is to press "CTRL+RSHIFT+ESC", kill the "explorer.exe" process and run it again as adminsistrator, then I have access to all this... but why do I have to do this even with the UAC turned down? Why does it still blocks acess to folders?

This also presents within the domestic group I created with my home pcs, in which I cannot access the files of other computers in the network (even though they were set to be shared within the network) unless I run "explorer.exe" as admin.

Anyone had this problem?


Edited by LucasAlmeida, 18 October 2016 - 11:18 AM.


BC AdBot (Login to Remove)

 


#2 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:08:13 PM

Posted 18 October 2016 - 02:23 PM

Tweaking.com - Windows Repair is a tool designed help fix a large majority of known Windows problems including; registry errors, file permissions, issues with Internet Explorer, Windows Updates, Windows Firewall and more. Download Tweaking.com - Windows Repair Tool and run the Tweaking.com - Windows Repair Tool from Safe Mode With Networking and  from Repairs tab click Open Repairs button. From opened Repairs window place check mark for  Reset Registry Permissions, Reset Service Permissions, Register System Files, Repair WMI, Remove Policies Set By Infections,  Restore Important Windows Services, Set Windows Services To Default Startup, Repair Windows 8/10 Component Store, Restore Windows 8/10 COM+ Unmarshalers, Restore UAC (User Account Control) Settings, Repair Hosts File, Repair Performance Counters, Repair Volume Shadow Copy Service, Repair MDAC & MS Jet and Reset File Permissions check boxes and click Start Repair button.


2GvnEq2.gif


#3 Ignisinitium

Ignisinitium

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:13 PM

Posted 19 October 2016 - 12:25 AM

icacls c:\folder /grant "everyone":(OI)(CI)M
To give permission may work as well

Edited by Ignisinitium, 19 October 2016 - 12:26 AM.


#4 LucasAlmeida

LucasAlmeida
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:13 PM

Posted 19 October 2016 - 06:43 AM

Hi, Ignisinitium

Thanks! Gonna try that once I get home.

Was wondering if takewon wouldn't also do the trick, but since I already changed ownership on the folders and it didn't work, I guess it wouldn't do any difference to do it throug cmd.

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users